Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have this message in dmesg log with linux 3.11.6-1 (2013-10-27) (debian version).

I wonder how to fix/remove it?

     [    5.098132] ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \PMIO 1 (20130517/utaddress-251)
     [    5.098147] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
     [    5.098156] ACPI Warning: 0x0000000000000530-0x000000000000053f SystemIO conflicts with Region \GPIO 1 (20130517/utaddress-251)
     [    5.098167] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
     [    5.098171] ACPI Warning: 0x0000000000000500-0x000000000000052f SystemIO conflicts with Region \GPIO 1 (20130517/utaddress-251)
     [    5.098180] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
     [    5.098186] lpc_ich: Resource conflict(s) found affecting gpio_ich
     [    5.099072] ACPI Warning: 0x000000000000f040-0x000000000000f05f  SystemIO conflicts with Region \_SB_.PCI0.SBUS.SMBI 1    (20130517/utaddress-251)
     [    5.099085] ACPI: If an ACPI driver is available for this device,     you should use it instead of the native driver

lspci :

$ lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.5 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 6 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 35)
03:00.0 SD Host controller: O2 Micro, Inc. Device 8221 (rev 05)
share|improve this question
1  
What hardware is this? –  schaiba Oct 28 '13 at 22:23
    
I updated my answer with lspci. –  ppr Oct 29 '13 at 23:09

1 Answer 1

up vote 4 down vote accepted
+50

This message is about some driver being denied access to devices controlled by the ACPI.

By and large, my experience is that it can be safely ignored. If however you really insist on removing the warnings, I suggest you do not try booting with the option acpi=off, or maybe you try just once to see what happens. But I am afraid you might find you have troubles with wifi, bluetooth, .... However here they say that this is mostly harmless, so no harm in trying.

One possible way to fix it is to boot with the option

 processor.nocst=1

which introduces compatibility with some old ACPI software, see here. An alternative is to use the option

 acpi_enforce_resources=lax

which obviously allows loading the drivers. This might, or not, interfere with ACPI operations.

Just for the sake of completeness (apologies if you already know this), to introduce these modifications, edit /etc/default/grub and replace

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 

with

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off" 

or whichever option you decide to try. Update grub, reboot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.