Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Fedora 19 64 bit on my Samsung Series 9 Ultrabook and I have installed MySQL workbench 6 (mysql-workbench-community-6.0.7-1.fc18.x86_64) via the RPM downloaded from the MySQL website.

I'm unable to pin this application to favorites. I have tried creating the mysql-workbench.desktop at /usr/share/applications/ and copied the mysql-workbench.png icon into /usr/share/pixmaps/ file as follows:

[Desktop Entry]
Name=MySQL Workbench
Comment=MySQL Database Design, Administration and Development Tool

Any pointers would be appreciated.

share|improve this question

Once you have a desktop file created and in the right location, you're almost there. You can do one of two things:

  1. Bring up the overview and search for the application; once you've found it, right click and Add to Favorites or simply drag to the launcher dashboard.
  2. Set the dconf key /org/gnome/shell/favorite-apps, either using the dconf-editor GUI or the dconf command-line tool.


dconf read /org/gnome/shell/favorite-apps

to see the current list, and dconf write to set it.

share|improve this answer
Thanks for your reply. I should have mentioned that I did try to right click but I did not find any Add to Favorites option. However I have not tried dragging or dconf. I'll give those a shot and let you know what transpires. Can you confirm if you had the option to Add to Favorites upon right click? – Karthic Raghupathi Oct 30 '13 at 16:26
@KarthicRaghupathi Yes, I just confirmed. You need to find the icon in the Applications menu (panel? page? whatever it's called), or by searching in the Overview (mouse to the top left corner of the screen or hit the "windows" key). Finding it in a file manager won't do. – mattdm Oct 30 '13 at 16:31
I tried dragging the icon over and I thought it worked. But when I clicked on it, I got 2 Workbench icons in the favorites bar. One with the white mysql icon (which is pinned and has the option to add to favorites) and another called the mysql-workbench-bin with a blue icon (with which I cannot do anything). At this point I have decided to stop worrying about this issue as it seems to be taking more time than it is worth to fix it. So thanks for your help. – Karthic Raghupathi Nov 2 '13 at 17:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.