Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using Linux mint. And this is my kernel.

uname -a
Linux nithesh-desktop 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I was having a networking problem, when I had used Lubuntu. So, I installed Linux Mint, thinking that it was a software issue. But even when I had linux mint, the internet didn't work.

Critical info: During a lightning strike, my modem's motherboard fried, along with the ethernet port attached in the computer. I bought a new modem, and a new External Ethernet Port [RTL-8139/8139C/8139C+]. It had worked for a few days, before the internet crashed again. I was downloading a torrent (for about 26 hours), when it abruptly stopped working.

I was wondering whether this was due to 'collision'. EDIT: Through BIOS settings, I have disabled the inbuilt ethernet card.Even after that, the network isn't working.

ifconfig gives me this result.

eth0      Link encap:Ethernet  HWaddr 00:e0:5c:00:42:aa  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:190 errors:0 dropped:0 overruns:0 frame:0
      TX packets:190 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:27879 (27.8 KB)  TX bytes:27879 (27.8 KB)

I later found out that eth0 is my new ethernet card, and eth1 is the old, fried, non-working one.

[Note: The following was requested by M_dk ]

cat /etc/network/interfaces gives me the following output:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

sudo iptables -L -nv gives me the following output:

Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target     prot opt in     out     source               destination         

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target     prot opt in     out     source               destination

[Note: The following was requested by michas]

ip link gives the following output:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
link/ether 00:e0:5c:00:42:aa brd ff:ff:ff:ff:ff:ff

I have a question though. Is this a software problem or a hardware problem?

Please help! I've been suffering without internet for a month!

share|improve this question
    
Please append the output of: cat /etc/network/interfaces and sudo iptables -L -nv to your question. –  M_dk Oct 26 '13 at 5:07
    
@M_dk I have added the changes. –  Kitizl Oct 26 '13 at 5:24
    
@Jon Smith : I am using a usb modem that I had borrowed. I would like to use the internet through my Ethernet modem. –  Kitizl Oct 26 '13 at 6:38
    
what is the output of ip link? –  michas Oct 26 '13 at 8:51
    
Ok, it seems that you are using NetworkManager. Are you using the GUI to manage the interfaces? Please add the contents from the files in /etc/NetworkManager/system-connections/. –  M_dk Oct 26 '13 at 10:53

4 Answers 4

You should switch off the original on board Ethernet card in your BIOS, the new one will be used as eth0.

share|improve this answer
    
Please check the new edit –  Kitizl Oct 26 '13 at 9:21

Try to switch off the original ethernet card in your BIOS. Maybe they are conflicting?

share|improve this answer
    
Please check the new edit –  Kitizl Oct 26 '13 at 9:21

How do you manage your network interfaces? I assume Mint uses NetworkManager. There should be a some icon to activate and decativate you interfaces.

For debugging purposes it is probably easier to do things manually:

  • Use ip link to verify, that the cable is correctly connected. (If not it will tell you "NO-CARRIER" for that interface.)

  • Use sudo dhclient -d eth0 to configure your interface using dhcp. (Which is probably what you want.)

  • Use ifconfig to check for any new addresses on that interface.

  • Have a look at /var/log/syslog for any messages about problems.

Also check, what happens if you connect your cable to the other interface. Does ip link detect the carrier? Is dhclient able to talk to the dhcp server and setup that interface?

share|improve this answer
    
I have given the output for ip link sudo dhclient eth0 doesn't give any output: After pressing enter, the cursor just blinks. In the system log, I couldn't identify any. It just says something like "Unable to connect" after attempting to connect for a minute. And finally, what do you mean by connecting the cable to the other interface? I think I mentioned how it is completely destroyed right now. Only thing what it isn't doing is bursting into flames. –  Kitizl Oct 26 '13 at 9:24
    
Yes, you said it is probably destroyed. But at the moment both interfaces seem equally dysfunctional... - The idea was to use ip link to check for carrier on both interfaces. - If you get no carrier on the broken one, you can be pretty sure it is indeed broken. –  michas Oct 26 '13 at 10:11
    
Try running dhclient as sudo dhclient -d eth0. Are you sure, that the other end of the cable is connected to a router, which is able to do dhcp? –  michas Oct 26 '13 at 10:16

Your eth0 seems to have no IP address. Your new modem should have a DHCP server. Enable it (it already should be) and set-up your ethernet card to use the DHCP. Network manager in Debian based installations ignore the cards if they're configured using /etc/network/interfaces, so you can use any method you like.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.