Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a Mesh network here in my town, where every node creates the same client wlan with the SSID "kiel.freifunk.net".

In wicd I can connect to those networks, but I have to choose which of them.

In network-manager it was more handy: there was shown only one network with that SSID and if I moved through the room with my laptop, it automatically connects to the nearest network with that SSID name (I think that's called "roaming")

Is it possible to achieve this with wicd also?

share|improve this question

migrated from serverfault.com Oct 25 '13 at 22:53

This question came from our site for system and network administrators.

Have you tried the first comment suggestion here: bugs.launchpad.net/wicd/+bug/661373 ? – Mathias R. Jessen Oct 25 '13 at 0:14
I will try, but how can I test it? I have accepted all Networks im My house already... maybe tomotrrow, when I am in another part of the town. I will see if it connects automatically there now that I checked "Share these values for all the networks sharing this ESSID" on all those Networks – rubo77 Oct 25 '13 at 0:26
Remove all the accepted networks at home with the same SSID, except one, make sure the "Share these values..." is checked, then cover the AP with a chernobyl-style cement cask and see what happens ;-) – Mathias R. Jessen Oct 25 '13 at 0:41
@MathiasR.Jessen: can you post that as answer? I will mark is as correct. – rubo77 Feb 23 '14 at 16:10
up vote 1 down vote accepted

Remove all the accepted networks at home with the same SSID, except one (let's call this the "template"), and then make sure the "Share these values..." option is checked.

Now, the next time the "template" network can no longer sustain the connection, Wicd should recognize one of the other available networks as the same and try to roam to the next available AP

share|improve this answer
I can't find this in wicd-gtk; do I need to use a different client? – l0b0 Apr 23 '15 at 8:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.