Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I would like to associate the Start menu with the Windows key on the keyboard?

Screenshot of the start menu

share|improve this question

3 Answers 3

up vote 4 down vote accepted

In KDE 4, the sequence to find the shortcut key is

System Settings -> Keyboard and Mouse -> Global Keyboard Shortcuts -> Plasma Workspace

then modify the shortcut key for "Activate Application Launcher Widget". An alternative way to get to the shortcut is to simply right-click on the Kickoff menu and choose "Application Launcher Settings".

Additionally, unless you configure the Win key, it acts as a Meta modifier by default, and cannot be used as a shortcut. To change this, create a file ~/.xmodmap and put the following in the file:

keycode 115 = F14

This makes your system think the Win key is actually the F14 key. Note: different keyboards sometimes have different key maps for the Win key (i.e. on my Thinkpad, the keycode for the Win key is 133). You can use the application "xev" from the terminal to determine which keycode applies to your keyboard.

You can modify the file

/etc/kde/kdm/Xsession

and add the command

if [ -f $HOME/.xmodmap ]; then
/usr/bin/xmodmap $HOME/.xmodmap
fi

to the bottom of the file, which should load your .Xmodmap on startup.

  • Note: you should do the .Xmodmap creation and the Xsession modification and then logout/login (or run /usr/bin/xmodmap $HOME/.xmodmap) before attempting to modify the shortcut key.
share|improve this answer

It looks like you're using KDE so try:

Control Centre -> Regional and Accessibility -> Keyboad Shortcuts

and change the shortcut key in the Popup Launch Menu entry from Alt-F1 to the Win key.

share|improve this answer

I have Fedora 16, KDE 4.8.3, Right click on the launcher, select Application Launcher Settings, select Keyboard Shortcut and enter the key or key combination that you want. I did Win+F since the default Meta+F1 does not work on my setup

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.