Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to create a monitoring system for a remote machine using an IPMI Serial Over Lan (SOL) console. The remote OS is RHEL 6, the mobo manufacturer is Supermicro.

I've successfully enabled SOL redirection in the BIOS. This allows me to see the BIOS and kernel parts of bootup through an attached SOL console over IPMI.

Next, I followed the steps mentioned in many online articles to get my OS ( runlevel 3, just text terminal ) to redirect too.

The result is almost always the same : After making the changes to /etc/grub.conf, /etc/inittab, and /etc/securetty, i can see the grub menu through the SOL console (yay!), but as soon as the OS starts booting, my SOL terminal receives 1 gibberish character, and nothing more.

Some thoughts:

  1. I'm not exaclty sure which serial port my BIOS are trying to redirect stuff into (ttyS0, ttyS1). Most of the examples use ttyS1, and since the grub menu gets redirected there, i'm pretty confident thats 'correct'

  2. I know the 'terminal types' and baud rates have to match between the BIOS and OS settings. I am consistently using 115200 for baud, but i'm less confident I'm choosing the right terminal type. The terminal type in BIOS is "ANSI", and this gives the coloration i want for the BIOS over SOL. However, for the OS settings, most of the examples use 'linux'; i'm not sure if that's compatible with my ANSI setting. I've tried VT100 for both BIOS and OS, and I still never see anything past the Grub menu (plus, i lose color info for my BIOS over SOL).

Any help is greatly appreciated.

share|improve this question

migrated from stackoverflow.com Oct 18 '13 at 0:38

This question came from our site for professional and enthusiast programmers.

    
Offtopic, voting for migration to serverfault.com –  fvu Oct 11 '13 at 13:03
    
Oops. I'd never heard of serverfault. That looks like a more appropriate place. Can I move it myself? or wait for a moderator? or should I just copy/paste the question there and delete this one? –  user2870990 Oct 11 '13 at 13:11
    
Maybe better copypaste it to serverfault yourself and delete this one, not much voting members online today it seems :-) –  fvu Oct 11 '13 at 13:14
    
I don't think this is on topic at ServerFault, unless the original users is a professional sysadmin. SuperUser seems like a better choice. –  dsolimano Oct 16 '13 at 16:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.