Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Latest flash rpm and tarball has forsaken my machine with fedora core 3 OS.

There are two browsers currently installed in the System. Firefox 2.0.x and Opera 10.11. Those two browsers do not display flash content.

I tried to install the latest FlashPlayer plugin in the browsers. But Installing RPM displayed a list of missing dependencies. And even after I copied the libflashplayer.so file into the plugin path of the browsers they wont show me flash content.

Since I am not permitted to upgrade the OS, which would result in loss of important data, I only want the earlier version of Flash player rpm or tarball for Linux(fedora Core 3).

  1. From where can I find oldest FlashPlayer rpm or tarball, for Linux?
  2. If it is not possible to install the flash plugin, then what are the other alternatives?

Thanks.

share|improve this question
    
A few details would be helpful here. What rpm did you try to install, what distribution/version did it correspond to, and it would be very helpful to post the error message about failing dependencies. Fedora 3 is really old, but I would have thought a flash plugin would be available for it/regardless. Also, I assume you are checking the plugins: url in your browser (I forget the exact syntax) to check if your browser is seeing the pluging? –  Faheem Mitha Mar 19 '11 at 15:44
    
Sorry, forgot to prefix your name. Also, is there some reason you are not using yum or similar to do the installation, since it does dependency handling? –  Faheem Mitha Mar 19 '11 at 15:58
    
in terms of alternatives it would depend what you are trying to do. If you want a flash plugin but can't install a flash plugin you have no alternatives :-) If you just want to browse youtube for example, you maybe do have an alternative (if you can get an html 5 browser on that box) –  Rory Alsop Mar 20 '11 at 0:16

2 Answers 2

up vote 3 down vote accepted

Fedora Core 3 reached end of life on January 16th, 2006. That means there have been no security updates for over five years. Half a decade!

This is the problem you need to solve:

Since I am not permitted to upgrade the OS, which would result in loss of important data,

What if the system were to die? Or, more importantly, what if known vulnerabilities in Firefox 2.0 and the old Linux kernel you are running enable an attacker to compromise your machine and destroy your data?

The answer to your question is: if you really need that FC3 box unchanged, you need to sandbox that system as completely as possible. It should not be talking to the public internet, and I'd be pretty suspicious about putting it near my internet network either. This isn't a theoretical concern — it's a real risk. And putting flash on there is only going to increase that risk.

So the answer really has got to be: don't use that system. If you need Flash — or web browsing in general! — use a different system. And that different system can (and should!) run a current, modern OS, and so running Flash will be no problem.

And find a way to make your data safe. Because this problem is only going to get harder, not easier.

share|improve this answer

1) Try Adobe binary installation. (Choose Linux -> tar.gz from Adobe download page)

2) For a free (as in freedom) alternative to Adobe Flash, take a look at Gnu Gnash. It works fine for me.

share|improve this answer
1  
Fedora Core 3 was released before Gnash was created. –  Tshepang Mar 20 '11 at 7:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.