Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running a Debian Wheezy (7.2), wich has a 64bit architecture, and wish to install cups and oracle xe on it. I installed cups through apt-get, and followed those steps to install oracle.

However, both programs depend on the bc package. When I installed oracle, it didn't work at first, and I had to install bc:i386 through apt-get.

My problem is that installing bc:i386 removes the amd64 version, thus uninstalling cups. When I try to reinstall cups, it removes both bc:i386 and oracle.

Is there a way around? I'm a bit lost and didn't find anything about my problem on Google.

share|improve this question
1  
the tutorial seems a bit outdated; you probably should enable multiarch support on your system, using dpkg --add-architecture i386 first. –  umläute Oct 16 '13 at 11:37
    
I tried it but i didn't display anything, and I don't wether it worked, failed, or did nothing. I tried to re install oracle after that, and failed for the same reasons as before –  Ploutox Oct 16 '13 at 11:45
1  
bc is not multiarchified yet, not even in unstable. You should file a bug to debian with reportbug. –  M Noit Oct 16 '13 at 11:57
    
Why not stick with the amd64 bc? What doesn't work if you do that, instead of forcing an i386 bc? You can't have both versions installed at the same time (because they use the same file names), but you shouldn't need to. –  Gilles Oct 16 '13 at 23:15
    
I'm forced to use 32bits due to the fact there is no 64bit linux version for oracle xe. I need bc i386 as a dependencie –  Ploutox Oct 17 '13 at 1:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.