Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm kind of desperately trying to make my wifi work on my newly-installed Debian Sid (amd64, kernel 3.10.11-1). The relevant line of the output of lspci is :

06:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)

and this wi-fi card is not recognized :

# iwconfig
eth0      no wireless extensions.
lo        no wireless extensions.

in case you need it, here is the output of lshw -c network :

*-network NON-RÉCLAMÉ   
description: Network controller
produit: RTL8188CE 802.11b/g/n WiFi Adapter
fabriquant: Realtek Semiconductor Co., Ltd.
identifiant matériel: 0
information bus: pci@0000:06:00.0
version: 01
bits: 64 bits
horloge: 33MHz
fonctionnalités: pm msi pciexpress cap_list
configuration: latency=0
ressources: portE/S:3000(taille=256) mémoire:f1d00000-f1d03fff

So I looked up online to find what driver I was supposed to install. I found that I was supposed to go to this page and install the rtl8192ce driver. I downloaded and extracted it, and followed the instructions of the readme file. I changed to super user and tried to compile the driver from the code source with make. Here is the output :

# make      
make -C /lib/modules/3.10-3-amd64/build M=/home/damien/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013 modules
make[1]: entrant dans le répertoire « /usr/src/linux-headers-3.10-3-amd64 »
  CC [M]  /home/damien/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.o
In file included from /home/damien/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.c:39:0:
/home/damien/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/pci.h:247:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rtl_pci_probe’
 int __devinit rtl_pci_probe(struct pci_dev *pdev,
               ^
/home/damien/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.c: In function ‘rtl_action_proc’:
/home/damien/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.c:885:32: error: ‘struct ieee80211_conf’ has no member named ‘channel’
       rx_status.freq = hw->conf.channel->center_freq;
                                ^
/home/damien/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.c:886:32: error: ‘struct ieee80211_conf’ has no member named ‘channel’
       rx_status.band = hw->conf.channel->band;
                                ^
/home/damien/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.c: In function ‘rtl_send_smps_action’:
/home/damien/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.c:1451:24: error: ‘struct ieee80211_conf’ has no member named ‘channel’
   info->band = hw->conf.channel->band;
                        ^
make[4]: *** [/home/damien/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013/base.o] Erreur 1
make[3]: *** [_module_/home/damien/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013] Erreur 2
make[2]: *** [sub-make] Erreur 2
make[1]: *** [all] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-headers-3.10-3-amd64 »
make: *** [all] Erreur 2

It seems that the error comes from the source code, and not from a lack of library or something.

Any idea of what I should try to do next, or how should I try to solve this compilation error ?

share|improve this question
2  
Did you try to install firmware-realtek and reboot? –  schaiba Oct 15 '13 at 12:22
    
… Damn. I spent two hours on this this morning, and I'm pretty sure it's the first time I see this solution. And I'm not the first one to have had this problem… It works perfectly now. Thank you so much! –  user49257 Oct 15 '13 at 14:26
    
@schaiba Please post this as an answer. –  Gilles Oct 15 '13 at 19:19
add comment

1 Answer 1

up vote 0 down vote accepted

Please enable contrib and non-free in /etc/apt/sources.list, install firmware-realtek and reboot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.