Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My laptop sees wireless ssid and connects but I get unknown host when trying to ping www.google.co.za, but I get replies when I ping 8.8.8.8, my other machine connected to the same router can surf the net no problems. I have tried adding nameserver but the laptop keeps loosing the configurations every now and then. Please help!

/etc/resolf.conf after I added nameserver 8.8.8.8 by hand:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.0.1
share|improve this question
    
Please provide more information, for example a routing table. Are you using NetworkManager as the tag implies? That might be overwriting your configuration set by hand. –  peterph Oct 15 '13 at 10:15
    
I have a normal ADSL router which is connected to telkom line and getting my IP from service provider. I use cat5 on the rest of the machines and wireless on this specific laptop. My connection is normal IP from ISP and therefore I attached machines to a normal ADSL router, my routing is not complicated. Hope this answers the question Peterph. Could that still be overwritting my config file? –  luclanpowr Oct 15 '13 at 10:27
1  
Oh, sorry I misread your question - routing doesn't seem to be the problem indeed. I believe NM could be overwriting your setup. What does your /etc/resolf.conf look like? –  peterph Oct 15 '13 at 11:07
    
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN nameserver 127.0.0.1 - this is after I edited my file and added nameserver 8.8.8.8 –  luclanpowr Oct 15 '13 at 11:25
    
Next time please add it into the question (using the edit button. :) As you can see, it even tells you that any changes will be lost. I'm afraid we'll need to know more about what distribution (end version) you are using. –  peterph Oct 15 '13 at 11:46
add comment

1 Answer

Which OS do you work with? If it's Ubuntu, check out this link: http://askubuntu.com/questions/2321/what-is-the-proper-way-to-change-the-dns-ip

If not, you may still be able to adapt the steps to your system... I think it's not as easy as just editing /etc/resolv.conf on your machine. I think it will be overwritten by Networkmanager. As an alternative, you could possibly disable Networkmanager and work with the "old" ifup and ifdown scripts, but you might use some comfort like automatic WiFi network selection and so on...

share|improve this answer
    
Thanks TomS, I have done all this steps in GUI and on terminal - but no matter what I do, the nameserver get scratched from /etc/resolv.conf file. Any idea what else to do!!! –  luclanpowr Oct 15 '13 at 11:44
    
Oooopsss! I am running Linux Mint 13 Maya \n \l –  luclanpowr Oct 15 '13 at 11:49
    
how many network connections do you use? One? more? What are the exact settings for the DNS server for each of the network connections? –  TomS Oct 15 '13 at 11:52
    
I've got three more machines on the network and the dns servers on them are 10.0.0.2. I have tried the same IP on this laptop and it just ignores it. My route -n are pointing to the same Ip and 8.8.8.8 –  luclanpowr Oct 15 '13 at 11:56
    
what are the contents of what does cat /etc/resolv.conf say? What does nm-tool | grep -i dns show? –  TomS Oct 15 '13 at 12:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.