Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My laptop is ThinkPad T61, with Ubuntu 10.10 installed. The sound works all well, until I plugged the Creative XiFi Go USB sound card. After I reboot my computer, the internal speaker is muted automatically. I have to use 'alsamixer' to unmute it each time. How can I persistent this setting?

share|improve this question
    
@Alaukik: although Ubuntu is the distribution involved, this isn't particularly Ubuntu-specific. When questions and answers could be generally useful to people not running Ubuntu, they're better here. –  mattdm Mar 19 '11 at 14:10
add comment

1 Answer 1

up vote 1 down vote accepted

The command you want to execute is:

amixer sset Master 50%

To have it run when you login, add it to System > Preferences > Startup Applications as the command.

To have it run at boot time, add it to your /etc/rc.local file.

share|improve this answer
    
I have tried this before. But my question is why this happens only after I used my USB sound card? There must be something wrong in the System setting. –  davidshen84 Mar 20 '11 at 2:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.