Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I set my HTTP proxy via Settings -> Preferences -> Network setup, and am getting this error:

Looking up irc.us.gimp.org
Looking up <IP>
Connecting to <IP> (<IP>) port <PORT>...
HTTP/1.1 502 Proxy Error ( The specified Secure Sockets Layer (SSL) port is not allowed. ISA Server is not configured to allow 
Proxy traversal failed.
Stopped previous connection attempt (pid=4696)

(<IP> and <PORT> are substitutions)

Without that setting (the IP:PORT is left empty), I'm getting this error:

Looking up irc.us.gimp.org
Connecting to irc.us.gimp.org ( port 6667...
Connection failed. Error: Connection refused
share|improve this question
A few words on ISA Server – forcefsck Mar 18 '11 at 15:37
See this answer. Your proxy doesn't allow CONNECT to port 6667, so you'll have to find an external relay. – Gilles Mar 18 '11 at 20:38
@Gilles: If this comment was an answer, it could be accepted, shouldn't it? – user unknown Jul 30 '11 at 20:55
up vote 2 down vote accepted

Your failing to reach XChat through the proxy because your proxy is specifically set to deny you this privilege. Talk to whoever configures or maintains the proxy and see if they'll allow this.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.