Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried both my own builds of Chromium OS and Hexxeh's daily Vanilla builds, and neither work. I copy them over to my flash drive, but when I try to boot from it, nothing happens except my backlight flashing on and off a few times, then a reboot. System: Compaq Presario CQ50-140US http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01550071&tmp_task=prodinfoCategory&lc=en&dlc=en&cc=us&site=null&lang=en&product=3795225&key=null

share|improve this question

There is a guide at hexxeh.net.

  • Scroll down to the General info area

General Info

  • Choose your current system which you use when downloading the package.

1.1 For Windows Use WinRAR or 7zip to extract IMG file from the downloaded archive.

1.2 Use Windows Image Writer, then select the IMG file and select the USB device from the menu.

1.3 Click on "Write".

1.4 Boot from the newly created Chromium OS USB stick!

2.1 On Mac OS - simply download the easy to use builder application for mac to make your vanilla USB drive.

3.1 On Linux - extract the IMG file from the downloaded archive

3.2 At the shell, run the following (where sdX is your USB stick and ChromeOS.img is the path to the IMG file you extracted): dd if=ChromeOS.img of=/dev/sdX bs=4M

3.3 Boot from the newly created Chromium OS USB stick!

In addition to the above, and for completeness of this answer (but which you probably know), you might have to change your boot order in the BIOS. To do this restart the computer and press F2 (sometimes F8) and change the system boot order so that your USB port is higher than the internal disc drive.


When I did this my self, my USB pen drive (Kingston Travler 16GB) got corrupted. When formatting it It would only take 1GB, I saw many partitions on it using Windows Disk management which I could not delete and neither could I extend the 1GB partition. A Google search shows that this is a common issue with the Chrome OS.
However, there are tools out there that fixes the USB stick, for example "HP USB Disk Storage Format Tool" worked fine for me.

share|improve this answer
It didn't get "corrupted", you are merely formatting a 1GB partition (which is what was used by the installer). – Chris Down Dec 27 '11 at 14:25
@ChrisDown If it was not corrupted, then tell me why could the usual "Disk management" tool either format the other partitions on the stick or extend the 1gb partition? – AD. Dec 27 '11 at 14:32
Because the ChromeOS .img file actually contains two partitions, and Windows Disk Management doesn't like USB drives with more than one partition. In addition to this, Windows doesn't like ext2 partitions, which I believe these are. – WindowsEscapist Nov 27 '12 at 20:09
(They might just be ext2 on hard drive installs, though.) – WindowsEscapist Nov 27 '12 at 20:10
@WindowsEscapist Thanks, I don't remember if the partition type now. – AD. Nov 28 '12 at 15:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.