Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to get working WebGL on Firefox without success, I tried forcing WebGL in the Firefox configuration and updating the Mesa drivers, but it's still not working. It's working on Opera, so the problem isn't the driver... I have an integrated Intel HD Graphics...

about:support:

Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0
Adapter Description Tungsten Graphics, Inc -- Mesa DRI Intel(R) Ironlake Mobile x86/MMX/SSE2
Device ID   Mesa DRI Intel(R) Ironlake Mobile x86/MMX/SSE2
Driver Version  2.1 Mesa 7.10.3
GPU Accelerated Windows 0/1 Basic
Vendor ID   Tungsten Graphics, Inc
windowLayerManagerRemote    false
AzureCanvasBackend  cairo
AzureContentBackend none
AzureFallbackCanvasBackend  none

Graphic card info:

# lspci -v | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])

OpenGL version

# glxinfo | grep OpenGL
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile  x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 7.10.3
OpenGL shading language version string: 1.20
OpenGL extensions:

about:config (webgl properties):

webgl.can-lose-context-in-foreground;true
webgl.default-no-alpha;false
webgl.disable-extensions;false
webgl.disabled;false
webgl.enable-draft-extensions;false
webgl.force-enabled;true
webgl.force-layers-readback;false
webgl.lose-context-on-heap-minimize;false
webgl.max-warnings-per-context;32
webgl.min_capability_mode;false
webgl.msaa-force;false
webgl.prefer-16bpp;false
webgl.prefer-native-gl;false
webgl.shader_validator;true

I tried the WebGL test get.webgl.com, but it says that the browser support it but is not activated...

Any suggestion??

share|improve this question
    
What are the values of webgl.disabled and other webgl. preferences (in about:config)? –  peterph Oct 11 '13 at 17:17
    
I posted the values of webgl config! –  DGomez Oct 11 '13 at 17:25
    
Just to make sure, the message you are getting is: "Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card."? –  peterph Oct 11 '13 at 18:17
    
Yes, that's the message –  DGomez Oct 11 '13 at 18:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.