Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Recently I began to use my laptop (Dell Inspiron N5020) with an external display. I use the displays side-by-side, internal on the left, external on the right.

The problem is, however, that the display on the external monitor seems to be shifted to the right by a few pixels, and at the same time a few pixel wide column from the right edge of the internal display is duplicated on the left edge of the external. On a screenshot this is not visible. I illustrated what I'm actually talking about on this image: Illustration of the problem

The type of the external monitor doesn't seem to matter. Same thing with a Medion 1680x1050 monitor with VGA connector, and a Dell U2311H through HDMI. Also I tried to set various resolution combinations, and it seems to only happen when the internal monitor is at its native resolution (which is 1366x768)

(I have Linux Mint 15 x64 with Cinnamon.)

share|improve this question
You should check the output of xrandr to ensure that the two displays are not overlapping in their layout. They probably aren't, but it's worth checking, especially if your mouse is really showing on two monitors the way you depict it. You can easily rearrange the windows using the GUI-based arandr or using xrandr command-line options. (Another possibility is that perhaps you're just seeing the window decorations crossing over. I've experienced this in several WMs.) – billyjmc Nov 8 '13 at 4:00
I use arandr and xrandr, the displays definitely aren't overlapping. Also I found a workaround: I saved the setup script with arandr, then shifted the right display by two pixels to the right, so that logically there is a two pixel wide gap between them. Visually it's totally fine. If I take a screenshot, the gap is filled with random garbled pixels, which aren't visible physically. Drawback however: the mouse is not stopped at the inner edges of the screens. So I can't place auto hiding panels to the top of the internal display, or the bottom of the external one. – Emoryy Oct 15 '14 at 14:41

1 Answer 1

I had the exactly same problem, but found a different solution that does not have the drawbacks of your proposed solution. It turned out that there was a 2 pixel wide unused column on the left side of my arrangement, so instead of shifting the right display to the right, I shifted the left display (internal) to the left, covering that unused column. Everything is fine now. Here is how my scripts looks like:

xrandr --output VGA-0 --off --output LVDS --mode 1366x768 --pos -2x312 --rotate normal --output HDMI-0 --primary --mode 1920x1080 --pos 1366x0 --rotate normal

Observe the -2 on the first


share|improve this answer
Thanks, I tried it. But it seems the mouse still doesn't stop at the inner edges - at least this is the case in XFCE. – Emoryy Sep 16 at 7:47
I see what you mean. In my case I only get that in one of the borders, in which I don't need it to stop. Let's keep waiting for a better solution then. – lasaro Oct 16 at 15:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.