Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Once I attach the external monitor, the image on both monitors is activated but is messed up, just chaotic lines and colors, so that i cannot access the 'Displays' settings.

This never happened with the same laptop in Ubuntu 12.04 (nor in 12.10 or 13.04).

Also this happens only if I plug the cable while the computer is open. If I restart with the external monitor attached, both will work in parallel.

To recover my normal desktop without restarting, I go to console (ctrl-alt-f1) and then back (ctrl-alt-f7) - after having unplugged the vga.

Also, in most cases I can recover my image even without unplugging the external monitor if I run from shortcut xrandr --output LVDS --mode 1680x1050 --rate 60.1 --output VGA-0 --off to use only the internal display. Afterwards, I can use the external display if I activate it from 'Displays' while disabling the internal one (if I try to activate both, both will display just lines and colors).


After updating to the raring 3.8.0-31 kernel some behaviour changed that was initially reported here but after a while it all come back to what was said.

I finally updated the kernel to 3.12 and no improvement. Also updated the video driver from here.

My VGA: RV380 Radeon X600, M24, fully supported as explained here. I have used this laptop with ubuntu 11.10, 12.04, 12.10, 13.04 without seeing a such severe problem. Never used proprietary drivers


Setting to extended monitor does not work.


I have managed to printscreen the internal display while both enabled and caught this:

enter image description here

Ouput of xrandr external monitor disconnected:

~$ xrandr
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 4096 x 4096
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1680x1050+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1680x1050      60.1*+
   1400x1050      60.0  
   1280x1024      59.9  
   1440x900       59.9  
   1280x960       59.9  
   1280x854       59.9  
   1280x800       59.8  
   1280x720       59.9  
   1152x768       59.8  
   1024x768       59.9  
   800x600        59.9  
   848x480        59.7  
   720x480        59.7  
   640x480        59.4  
S-video disconnected (normal left inverted right x axis y axis)

External monitor connected, internal off:

~$ xrandr
Screen 0: minimum 320 x 200, current 1360 x 768, maximum 4096 x 4096
VGA-0 connected 1360x768+0+0 (normal left inverted right x axis y axis) 580mm x 320mm
   1360x768       60.0*+
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        60.0  
DVI-0 disconnected (normal left inverted right x axis y axis)
LVDS connected (normal left inverted right x axis y axis)
   1680x1050      60.1 +
   1400x1050      60.0  
   1280x1024      59.9  
   1440x900       59.9  
   1280x960       59.9  
   1280x854       59.9  
   1280x800       59.8  
   1280x720       59.9  
   1152x768       59.8  
   1024x768       59.9  
   800x600        59.9  
   848x480        59.7  
   720x480        59.7  
   640x480        59.4  
S-video disconnected (normal left inverted right x axis y axis)
share|improve this question
    
    
Please post the output of xrandr. –  terdon Oct 9 '13 at 17:25
    
Was that with the VGA screen connected? –  terdon Oct 9 '13 at 17:34
    
OK, then you should be fine. xrandr correctly identifies both displays. Try the command in my answer. –  terdon Oct 9 '13 at 18:04
    
@terdon - very sorry for the ambiguity. and thank you very much for all your effort. i have tried to clarify now. you should un-delete your answer: the command may be useful in the future, maybe for me or for others. –  cipricus Oct 9 '13 at 19:56
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.