Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have problem on graphic card with ACER V193w LCD display. I really don't know how to configure /setup/ Nvidia GeForce 9800 on Ubuntu 10.10. Can you guys please help me!

share|improve this question
    
First of all, do you have a proper driver installed? Ubuntu has recently made installing Nvidia drivers a snap. –  Mr. Shickadance Mar 17 '11 at 4:53

2 Answers 2

Here's my xorg.conf, sans comments, for a laptop with an Nvidia chip. You can start from here and edit it.

You an also try running the nvidia-xconfig tool, but it doesn't create proper configs for modern xorg servers. But you can cut and paste the driver part out and add it to this one.

Section "Files"
    FontPath    "/usr/share/fonts/misc"
    FontPath    "/usr/share/fonts/Type1"
    FontPath    "/usr/share/fonts/TTF"
    FontPath    "/usr/share/fonts/75dpi"
    FontPath    "/usr/share/fonts/100dpi"
    FontPath    "/usr/share/fonts/aquafont"
    FontPath    "/usr/share/fonts/urw-fonts"
    FontPath    "/usr/share/fonts/corefonts"
    FontPath    "/usr/share/fonts/sgi-fonts"
    FontPath    "/usr/share/fonts/cronyx"
    FontPath    "/usr/share/fonts/cyrillic"
    FontPath    "/usr/share/fonts/essays1743"
    FontPath    "/usr/share/fonts/freefonts"
    FontPath    "/usr/share/fonts/freefont-ttf"
    FontPath    "/usr/share/fonts/libertine-ttf"
    FontPath    "/usr/share/fonts/intlfonts"
    FontPath    "/usr/share/fonts/terminus"
    FontPath    "/usr/share/fonts/ttf-bitstream-vera"
    FontPath    "/usr/share/fonts/unifont"
    FontPath    "/usr/share/fonts/dejavu"
    FontPath    "/usr/share/fonts/mplus-outline-fonts"
    FontPath    "/usr/share/fonts/OTF"
    FontPath    "/usr/share/fonts/Speedo"
    FontPath    "/usr/share/fonts/stix-fonts"
    FontPath    "/usr/share/fonts/tengwar-fonts"
    FontPath    "/usr/share/fonts/thaifonts-scalable"
    FontPath    "/usr/share/fonts/unfonts"
    FontPath    "/usr/share/fonts/urwvn-fonts"
    FontPath    "/usr/share/fonts/vdrsymbols-ttf"
    FontPath    "/usr/share/fonts/liberation-fonts"
    FontPath    "/usr/share/fonts/arphicfonts"
    FontPath    "/usr/share/fonts/culmus"
    FontPath    "/usr/share/fonts/droid"
    FontPath    "/usr/share/fonts/efont-unicode"
    FontPath    "/usr/share/fonts/farsi-fonts"
    FontPath    "/usr/share/fonts/mathematica-fonts"
    FontPath    "/usr/share/fonts/mikachan-font-ttf"
    FontPath    "/usr/share/fonts/opendesktop-fonts"
    FontPath    "/usr/share/fonts/proggy-fonts"
    FontPath    "/usr/share/fonts/unifont"
    FontPath    "/usr/share/fonts/webby-fonts"
EndSection


Section "Module"
    Load    "dbe"
    SubSection  "extmod"
    Option  "omit xfree86-dga"
        Option  "omit apm"
    EndSubSection
    Load    "glx"
    Load    "v4l"
EndSection




Section "ServerFlags"
    Option  "blank time"    "5" # 10 minutes
    Option  "standby time"  "10"
    Option  "suspend time"  "20"
    Option  "off time"  "30"
EndSection

Section "DRI"
    Mode 0666
EndSection

Section "Monitor"
    Identifier  "MetaMonitor"
    Option      "DPMS"
EndSection

Section "Device"
    Identifier  "Nvidia"
    Driver  "nvidia"
    VendorName  "NVIDIA Corporation"
    BoardName   "Quadro FX 2800M"
EndSection

Section "InputClass"
    Identifier "synaptics"
    MatchIsTouchpad "on"
    Driver "synaptics"
    #Option "SHMConfig" "on"
    Option "VertTwoFingerScroll" "on"
EndSection

Section "Screen"
    Identifier  "Screen1"
    Device  "Nvidia"
    Monitor "MetaMonitor"
    DefaultDepth 24
    Option         "TwinView" "1"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1920+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


Section "ServerLayout"
    Identifier  "Main Layout"
    Screen  0 "Screen1" 0 0
    Option         "Xinerama" "0"
EndSection
share|improve this answer

Ubuntu does not install the nVidia binary drivers by by default so you need to install them yourself.

$ sudo apt-get update && sudo apt-get install nvidia-current nvidia-current-modaliases nvidia-settings

That should work for you. If you want the later version of the driver I found some simple instructions here for installing from a PPA repository.

Add the latest driver repository:

$ sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

Install the latest driver

$ sudo apt-get update && sudo apt-get install nvidia-current nvidia-current-modaliases nvidia-settings
share|improve this answer
    
Does the "install drivers" menu in Ubuntu do this automatically? Or you need to configure the repos first? –  Mr. Shickadance Mar 17 '11 at 14:11
1  
@Mr. The menu installs a binary driver automatically, no config required. (At least for Desktop 10.10 and a GeForce 210. The driver was also a suggested by the Ubuntu installer, so I didn't need to use the "install drivers" menu either.) But you need to configure the repository if you want a driver more recent than the one in the Ubuntu repo. –  j-g-faustus Mar 17 '11 at 17:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.