Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I cannot update as no mirror is found:

[root@localhost ~]# yum update
Loaded plugins: langpacks, refresh-packagekit
Could not get metalink https://mirrors.fedoraproject.org/metalink?repo=fedora-19&arch=i386 error was
14: curl#6 - "Could not resolve host: mirrors.fedoraproject.org; Name or service not known"
http://www.mirrorservice.org/sites/dl.fedoraproject.org/pub/fedora/linux/releases/19/Everything/i386/os/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: www.mirrorservice.org; Name or service not known"
Trying other mirror.
ftp://ftp.mirrorservice.org/sites/dl.fedoraproject.org/pub/fedora/linux/releases/19/Everything/i386/os/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: ftp.mirrorservice.org; Name or service not known"
Trying other mirror.

I can ping this and every other address that fails:

[root@localhost ~]# ping www.mirrorservice.org
PING www.mirrorservice.org (212.219.56.184) 56(84) bytes of data.
64 bytes from www.mirrorservice.org (212.219.56.184): icmp_seq=1 ttl=50 time=19.6 ms
64 bytes from www.mirrorservice.org (212.219.56.184): icmp_seq=2 ttl=50 time=19.6 ms
64 bytes from www.mirrorservice.org (212.219.56.184): icmp_seq=3 ttl=50 time=19.7 ms
64 bytes from www.mirrorservice.org (212.219.56.184): icmp_seq=4 ttl=50 time=20.1 ms
^C
--- www.mirrorservice.org ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 19.607/19.788/20.104/0.189 ms

UPDATE #1

Here's the output from the following command:

$ URLGRABBER_DEBUG=1,debug.log yum update
share|improve this question
    
Can you run it manually? curl http://www.mirrorservice.org/sites/dl.fedoraproject.org/pub/fedora/linux/release‌​s/19/Everything/i386/os/repodata/repomd.xml –  terdon Oct 8 '13 at 21:15
    
that giving issue Could not resolve host: mirrors.fedoraproject.org; Name or service not known So are you able to resolve mirrors.fedoraproject.org ? if possible post /etc/resolv.conf –  Rahul Patil Oct 8 '13 at 21:21
    
[root@localhost ~]# ping mirrors.fedoraproject.org PING mirrors.fedoraproject.org (152.19.134.146) 56(84) bytes of data. 64 bytes from vm7.fedora.ibiblio.org (152.19.134.146): icmp_seq=1 ttl=47 time=112 ms 64 bytes from vm7.fedora.ibiblio.org (152.19.134.146): icmp_seq=2 ttl=47 time=114 ms ^C --- mirrors.fedoraproject.org ping statistics --- 2 packets transmitted, 2 received, 0% packet loss, time 1001ms rtt min/avg/max/mdev = 112.452/113.565/114.678/1.113 ms –  Stramash Oct 8 '13 at 21:39
    
Adding the bytemark mirror to /etc/hosts has allowed me to update and install a browser... so there is something off in the way yum is DNSing? –  Stramash Oct 9 '13 at 22:51

2 Answers 2

metalink

Double check that you can download the metalink file from here:

$ curl 'https://mirrors.fedoraproject.org/metalink?repo=fedora-19&arch=i386' \
    -o metalink

ping fedoraproject

It looks like you're having an issue getting to that URL and not www.mirrorservice.org. Also make sure you can ping this site:

$ ping mirrors.fedoraproject.org

Other URLs in metalink file

Also if the metalink file is downloaded correctly, take a look inside it. There are additional URLs to repos in there, make sure that they're accessible too.

Turn up the debugging level

You can use this command to get more feedback from yum as to why it is unable to connect to repositories:

$ URLGRABBER_DEBUG=1,debug.log yum update

The output will be dumped to the screen and to the log file, debug.log. Please post this file using pastebin.com.

share|improve this answer
    
All of the mirrors fail but all can be pinged![root@localhost ~]# ping mirror.bytemark.co.uk PING mirror.bytemark.co.uk (212.110.161.69) 56(84) bytes of data. 64 bytes from mirror.bytemark.co.uk (212.110.161.69): icmp_seq=1 ttl=51 time=26.3 ms 64 bytes from mirror.bytemark.co.uk (212.110.161.69): icmp_seq=2 ttl=51 time=26.5 ms 64 bytes from mirror.bytemark.co.uk (212.110.161.69): icmp_seq=3 ttl=51 time=26.9 ms ^C --- mirror.bytemark.co.uk ping statistics --- 3 packets transmitted, 3 received, 0% packet loss, time 2002ms rtt min/avg/max/mdev = 26.356/26.629/26.967/0.253 ms –  Stramash Oct 8 '13 at 21:58
    
Pinging just proves that they're accessible via the network, not that the service is actually running at the other end that yum can connect to. See if your yum data files have become corrupted and remove them w/ this cmd: yum clean all. –  slm Oct 8 '13 at 22:29
    
Ping also proves they can be resolved which contradicts the error message. With 'yum clean all' the error persists. –  Stramash Oct 9 '13 at 6:08
    
@Stramash - true but the message says both: "Name or service not known". –  slm Oct 9 '13 at 11:58
    
@Stramash - see updates, please post the debug.log file I showed how to get. –  slm Oct 9 '13 at 12:50

Resolved this by adding nameserver 8.8.8.8 above my router's address in resolv.conf that was obtained by DHCP.

Not quite sure why it will not work with the automagic DHCP settings.

Thanks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.