Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I recently installed Debian wheezy on my desktop PC. Here is the uname -a command:

Linux devnet 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1+deb7u1 x86_64 GNU/Linux

Once the installation finished, I started installing some packages (chromium and JAVA7), but I've come across a problem and I don't know how to solve it.

When trying to install chromium, I get the following error:

caled@devnet:~$ sudo apt-get install chromium

Then asks for password and lists packages to be installed, everything fine. But then I get:

/bin/sh: 1: /usr/sbin/dpkg-preconfigure: not found
dpkg: error processing /var/cache/apt/archives/libc-bin_2.13-38_amd64.deb (--unpack):
 package architecture (amd64) does not match system (i386)
Errors were encountered while processing:
 /var/cache/apt/archives/libc-bin_2.13-38_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ok, from that I get that it is having a problem installing the libc-bin package for the amd64 architecture, but that is the correct architecture for my PC, uname -a says so.

I've tried multiple approaches: allowing i386 packages

sudo dpkg --add-architecture i386

Also installing dependencies:

sudo apt-get -f install

I also thought that it might be a trouble with my locales, but I generated my locales as root:

locale-gen

Finally, I gave it a shot by installing just the libc-bin package using synaptic, but still nothing has worked.

Any ideas what I could be missing? Any help will be greatly appreciated, stating to feel frustrated...

share|improve this question
    
What it the current output of dpkg --print-foreign-architectures? And dpkg --print-architecture? –  terdon Oct 8 '13 at 1:02
1  
Is the file /usr/sbin/dpkg-preconfigure really missing from your system? On my Wheezy box, this file belongs to the debconf package whose priority is "Required". So if you're missing this file, it means your debconf package installation was botched somehow. –  Joseph R. Oct 8 '13 at 1:06
    
Here are the outputs: 'dpkg --print-foreign-architectures' 'amd64' –  kn1ght Oct 8 '13 at 2:02
    
foreign-architecture: amd64 print-architecture: i386 If the debconf package is botched, is there a way to reinstall it? –  kn1ght Oct 8 '13 at 2:12
    
What is the output of file /usr/sbin/dpkg-preconfigure? To reinstall debconf, do apt-get --reinstall install debconf (however this might fail depending on how your system is hosed). What sources do you have — what do you have in /etc/apt/sources.list and /etc/apt/sources.list.d/*.list? –  Gilles Oct 8 '13 at 21:38

2 Answers 2

After trying to reinstall the debconf file, I decided to install Debian from scratch. Now everything is working fine. Just to answer the last questions. dpkg-preconfigure is a Perl Script, ASCII text executable. I manually added a couple of sources to the sources.list, but i also tried deleting those and it did not work. In my current list are the wheezy main and updates servers. Lesson learned: be careful with the packages you uninstall (specially the essential ones :P). Thanks anyway for the help!

share|improve this answer

It's unusual to use sudo on a Debian system. So it might just have been a permissions problem. Next time try adminstrator account via su

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.