Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running an Ubuntu Server that boots to the console. After a long wile, the screen goes blank and I cannot type or unblank the screen. Even the caps lock / num lock do not change states. I am however, able to SSH into the computer.

Is there a way I can unblank the tty1 over SSH?

Is it possible to do this from the keyboard + not logged in + blank screen?

share|improve this question
Try changing the terminals (as root): chvt 2; chvt 1 (to VT2, then to VT1). – peterph Oct 7 '13 at 16:25
That did something. Changing to vt2 changed the state of numlock and back to VT1 restored it. But it did not unblank the screen. I typed my credentials blink on VT2 and logged in. I see myself by typing who over ssh. But the screen is still blank! :-( – Lord Loh. Oct 7 '13 at 16:29
Try this: askubuntu.com/questions/138918/… – Michael Durrant Oct 7 '13 at 16:32
This is the same as setting /sys/module/kernel/parameters/consoleblank to 0. It is already 0. – Lord Loh. Oct 7 '13 at 16:35
try setterm -blank poke – peterph Oct 7 '13 at 16:37
up vote 0 down vote accepted

I found a working answer on Server Fault from reddit.

Even though I did disable blanking, the screen still goes blank, but I can bring it back with a key press. I can live with that for now.

The trick was to install console-tools and configure it from /etc/console-tools/config to have


Added on 2013-11-15: After an update, this broke down again! The display would blank and never unblank. This time I had to update the file in /etc/kbd/config. After fixing the file the computer remained on all night without blanking the display.

share|improve this answer

You can use :

setterm -blank poke --term linux < /dev/tty1
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.