Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After start GNOME prints Hardware disabled. I've tried to use keyboard shortcut and it doesn't work. Only way to disable/enable hardware wifi is to put laptop into sleep mode and restore.

share|improve this question
add comment

3 Answers

Also can check RF kill switches, try "rfkill list all", and if thats interesting persue further.

share|improve this answer
add comment

I think the following should work: ip link set wlan0 up. Of course I'm not sure your wifi interface is wlan0, but you can check it by running: iw dev, and if it's like wlan1, just replace wlan0 with it.

share|improve this answer
add comment

I don`t have a problem to enable my wifi. My problem is that when i turn to sleep mode and resume it says that wifi is hardware disabled and the only way to enble it is to turn it to sleep mode again and resume it. It seems like the the fn+f1(sleep) and the fn+f2(sleep) are the same.

share|improve this answer
    
You shouldn't post this as an answer. If you think that some answer needs clarification, just comment to that answer. Also, now you say that your laptop's wifi turns off when you resume from sleep, and your question says almost opposite. –  Risto Salminen Oct 9 '13 at 13:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.