Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have created the following .desktop file in ~/.local/share/applications, when I search "Nightly" Nightly appears in search results with the correct icon(earth at night), but when I opened it it shows as Firefox in Dash. How can I make it show as Nightly? I used Fedora 19 with Fedora Desktop.

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
NoDisplay=false
Exec=/home/yang/Apps/firefox/firefox %u
Name=Nightly
Comment=Custom definition for Nightly
Icon=/home/yang/Apps/firefox/browser/icons/mozicon128.png
share|improve this question

2 Answers 2

if firefox is already running, it do not open a new instance but connect to the old one (try to close firefox and open the link to see that it opens nightly)

what you need to do is to open it with --no-remote option

Exec=/home/yang/Apps/firefox/firefox --no-remote %u

EDIT:on some systems it -no-remote (one minus character)

share|improve this answer
    
No, it's not because of this –  yanglifu90 Oct 6 '13 at 15:52

two versions of firefox might have problem working on the same profile

try to open it with -P (in addition to --no-remote), for the first time it will open the profile manager, create another profile and from now on open it with

Exec=/home/yang/Apps/firefox/firefox --no-remote -P aurora %u
share|improve this answer
    
Not working either. –  yanglifu90 Oct 7 '13 at 3:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.