Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have already asked this question on stackoverflow, but it's also a linux related question and somebody here might know a solution. Hope it's okay.

Problem is that I can't run 3D visualisation in Paraprof program on ARM Linux. I am running a small cluster (8 nodes) using armhf Debian Wheezy 7.1 with OpenMPI.

I am using Tau OpenMPI profiling tool and it's got a very nice visualising tool called Paraprof.

I have a problem with 3D visualisation with paraprof. When I try to run it it says that:

/home/cluster/tool/tau-2.22.2/lib/libjogl_drihack.so :/home/cluster/tool/tau-2.22.2/lib/libjogl_drihack.so cannot open shared object: No such file or directory

I think it's a problem with libraries paths settings, because the path is doubled. Interestingly libjogl_drihack.so is in this directory. LD_LIBRARY_PATH is set correctly as:


OpenGL is installed (I can run glxinfo) and all libjogl packages.

Attaching screenshots. https://www.dropbox.com/s/x54xpo5c2kjzew8/tau1.png https://www.dropbox.com/s/mimze22pcl6vxkq/tau2.png

Some more info:

root@master:~# ldd
    not a dynamic executable
root@master:~# ls /home/cluster/tools/tau-2.22.2/arm_linux/lib/lib*.so
root@master:~# uname -a
Linux master 3.8.13-bone26 #1 SMP Fri Aug 16 20:56:24 UTC 2013 armv7l GNU/Linux


root@master:~$ glxinfo | grep OpenGL
OpenGL vendor string:Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 2.1 Mesa 8.0.5
OpenGL shading language version string: 1.20
OpenGL extensions

The configuration script for Tau, was looking for libGL.so in /usr/lib directory, on my system this file is in /usr/lib/arm-linux-gnueabihf so i copied it to the /usr/lib, but still no luck. The same error persits.

share|improve this question
Thanks for acknowledging your cross-post here, but you should have done it in the S.O. post too! – goldilocks Oct 5 '13 at 14:33
    not a dynamic executable

This means what it says. It's one or more of:

  • Not a real .so file.
  • Not executable.
  • Compiled for a different architecture.

Check the output of file libjogl_drihack.so (you need the correct path there).

I'm not an openMPI or Tau user, but I notice there is a Tau package available for armhf Wheezy (or at least, there is for raspbian). However, I doubt this would install into /home/cluster, so evidently you are using something else.

If you compiled the whole thing on the system, this shouldn't happen either. But if you copied/built the binaries from somewhere else, that's your problem (note there is more than one ARM architecture). Do you have a reason for not using the distro package?

share|improve this answer
Compiled for a different architecture is probably right — it's probably an armel library on an armhf system. – Gilles Oct 5 '13 at 14:46
Thanks, I'll try to recompile these libraries and we'll see if it works.. – zdun8 Oct 5 '13 at 21:01
Recompiling jogl.1.0.0 is not so trivial on armhf as it would seem.. New jogl doesn't generate the files that I need unfortunately. – zdun8 Oct 6 '13 at 0:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.