Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was not able to ftp to my remote server. I read Ubuntu doc to see how to resolve: https://help.ubuntu.com/10.04/serverguide/ftp-server.html

Just now I installed vsftpd on my remote machine. Now when I run

ftp rs

it's saying :

ravbholua@ravbholua-Aspire-5315:~$ ftp rs
Connected to ravi.com.
220 (vsFTPd 3.0.2)
331 Please specify the password.
530 Login incorrect.
Login failed.

You see here it says to specify a password but it is not waiting for me to input password. Automatically it proceeds ahead and messages login failed.

How to resolve? (Also I would appreciate if any material/link can be provided to me)


@dru please see the content of the configuration file

$ cat /etc/vsftpd.conf

# Example config file /etc/vsftpd.conf
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
# Run standalone?  vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
# Run standalone with IPv6?
# Like the listen parameter, except vsftpd will listen on an IPv6 socket
# instead of an IPv4 one. This parameter and the listen parameter are mutually
# exclusive.
# Allow anonymous FTP? (Disabled by default)
# Uncomment this to allow local users to log in.
# Uncomment this to enable any form of FTP write command.
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
# If enabled, vsftpd will display directory listings with the time
# in  your  local  time  zone.  The default is to display GMT. The
# times returned by the MDTM FTP command are also affected by this
# option.
# Activate logging of uploads/downloads.
# Make sure PORT transfer connections originate from port 20 (ftp-data).
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
# You may override where the log file goes if you like. The default is shown
# below.
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
# You may change the default value for timing out an idle session.
# You may change the default value for timing out a data connection.
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
# (default follows)
# You may restrict local users to their home directories.  See the FAQ for
# the possible risks in this before using chroot_local_user or
# chroot_list_enable below.
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
# (default follows)
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
# Customization
# Some of vsftpd's settings don't fit the filesystem layout by
# default.
# This option should be the name of a directory which is empty.  Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
# This string is the name of the PAM service vsftpd will use.
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.
# This option specifies the location of the RSA key to use for SSL
# encrypted connections.
share|improve this question
Can you post the config file (e.g. /etc/vsftpd.conf)? – druciferre Oct 4 '13 at 3:17
I commented the line mentioned in ~/.netrc file and now when I run ftp rs, it asks for username and password. ravbholua@ravbholua-Aspire-5315:~$ cat .netrc #default login anonymous password ravisingh1@rediffmail.com ravbholua@ravbholua-Aspire-5315:~$ But still it's not very clear as how .netrc works in ftp. Any suggestion please for clarification. – Ravi Oct 4 '13 at 13:12
Your vsftpd.conf looks okay to me, you might want to uncomment the #chroot_local_user=YES line though for security reasons. I would suggest trying apt-get purge vsftpd and apt-get install vsftpd and see if it makes a difference. – druciferre Oct 4 '13 at 17:17
up vote 1 down vote accepted

Not quite sure why vsftpd.conf is quoted as looking okay above... The question asks why anonymous FTP doesn't work, and the line "anonymous_enable=NO" is in the config file, so thats one point of note.

Since the FTP client didn't bother to prompt you for a password, I'd assume its "auto" logging in as anonymous - since decades gone by the standard for this is the username "anonymous" or "ftp" and an email address as the password (which everyone always fakes).

I don't know what ftp client you have connected to your "ftp" command, but if its something like ncftp it will just anon login unless you put "-u username" in the parameters.

Thats my two cents on both parts anyway, need more to go on to understand your ftp client's behaviour really.

share|improve this answer
Thanks for you assistance. But please also note the comment (which is also somewhat an answer to my own question) I sent in 1st post. There is a file in my home directory: ~/.netrc. The content of the file was : default login anonymous password ravisingh1@rediffmail.com. When I commented it by putting a hash sign in the beginning of the line, then when I run ftp rs, it asks for username and password. – Ravi Oct 5 '13 at 2:46
I would appreciate if you can tell how to know which ftp client is here that's connected to ftp command. – Ravi Oct 5 '13 at 6:44
Try "which ftp" then ls -l the file it points to, its probably a symlink back to /etc/alternatives - "ls -l" that and see when it redirects back to (netkit-ftp for me). – iain Oct 6 '13 at 2:51
Also, it's still not clear to me what the actual problem here is - the topic suggests "enabling anonymous logins in vsftpd" which I commented on, but the majority of the conversation is now more about an FTP client :) – iain Oct 6 '13 at 2:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.