Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

have the following setup

Raspberry pi with samba installed and running

Windows 8 machine that can see the samba share, access the proper DIR, see all contents

In the smb.conf file, at the base of the file, I created the above dir with this

[AirLock]
comment = AirLock
path = /thepath/
writeable = Yes
create mask = 0777
directory mask = 0777
browseable = Yes
public = Yes
read only = no

With these settings I can see the whole dir that I want but I cant create files, edit files, or create DIRs.

I need to do all of this.

share|improve this question

2 Answers 2

So after a TON of head ache the answer, as I suspected, was as simple as it was rediculous.

My smb.conf was fine

The problem was that I was attempting to create my share dir within /var/www and that dir didn't have write permission enabled.

I executed the following line and it all just worked from then on out.

sudo chmod 0777 /var/www 
share|improve this answer
    
Careful with making things like /var/www 0777. That means anyone and anything can create files in there. And since presumably you are running a web server pointed there, any compromise in the web server allows arbritrary files to be created. –  kurtm Oct 6 '13 at 16:21
    
@kurtm I suspected that. Is there a way to limit that permission to an ip? –  Anthony Russell Oct 6 '13 at 16:29
    
The filesystem knows nothing about IPs. The web server would be enforcing that restriction, but if it gets compromised, the OS allows anyone to write anything in there. –  kurtm Oct 6 '13 at 16:32
    
@kurtm I suppose its very easy for me to just set those permissions when I need them. Thanks for the heads up –  Anthony Russell Oct 6 '13 at 16:48

It's related to your authentication.you set ok, but please add some auth directive and do smbpasswd . You don't have any problem in filesystem layer.Oh, recall your setting doesn't have problem in XP but have problem in win7. check your win.

share|improve this answer
1  
I have no idea what you're trying to say (your English is often incomprehensible), but it doesn't appear to answer the question at any point. –  Gilles Oct 2 '13 at 22:33
    
yes, unfortunately my English language is vey weak, i'm working now...! –  Mohsen Pahlevanzadeh Oct 3 '13 at 12:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.