Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to create a custom live distribution of Fedora. I am using Fedora 19 live CD on VirtualBox on Windows (64bit Macbook Pro) to do this. I have tried following on Fedora 19 32 bit, Fedora 19 64 bit and Fedora 18 64 bit with same result:

Revisor (Create Your Own Fedora Distribution with Revisor) - this freezes on "Loading Repositories". I have also tried using the following command and it got stuck in loading repositories at 18%:

revisor --cli --config=/etc/revisor/revisor.conf --model=f19-x86_64 \
--kickstart=/livecd/fedora-live-base.ks --respin \
--live-usb-thumb --live-shell


livecd-creator - I used the following command and it just froze (I kept it running for half an hour but nothing happened)

livecd-creator --config=/root/fedora-live-base.ks --fslabel=Fedora-LiveCD --cache=/var/cache/live


mock (How to create a Fedora install ISO for testing) also freezes on "Start: yum update"


I have checked my internet connection and that is working fine. Can anyone please suggest any solutions or alternatives to this?


Update: I tried the command livecd-creator on Fedora 19 32-bit as follows:

livecd-creator --verbose --config =/livecd/fedora-live-desktop.ks --fslabel=Fedora-LiveCD --cache=/var/cache/live

I can see it is retrieving many packages but randomly (I tried 5 times) gets stuck at one of the packages like gnome-* (like gnome-calculator, gnome-keyring, etc.)

Any idea what is happening???

share|improve this question
add comment

closed as off-topic by Braiam, slm, jasonwryan, Anthon, Thomas Nyman Apr 9 at 5:34

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Braiam, slm, jasonwryan, Anthon, Thomas Nyman
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

In the end, I gave up on VirtualBox. I installed Fedora 19 on VMWare Workstation and the commands worked fine.

share|improve this answer
    
Glad that you got it worked in VMWare. But since your question was concerned with VirtualBox, you can add this answer as an edit to your question rather than posting as an answer. –  Ramesh Apr 8 at 23:14
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. –  slm Apr 8 at 23:19
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.