Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I was assigned a workstation where I work and I needed to install Debian on it. I chose Wheezy because the other machines I use also have it, but I ran into a problem.

The workstation is a Dell Optiplex 990 (I should've opted out of it.), and it has the following ethernet card on it:

$ lspci | grep Network

$ Intel Corporation 82579LM Gigabit Network 

Apparently, the stable release of Debian 7.1 does not support this driver. The best way to update the more up-to-date version would be to just compile the newer driver.

This is where my trouble begins though. To compile the driver, I need a kernel development package. To create the kernel development package and compile the custom kernel, I need a boatload of other packages (notably gcc, make, etc.) that have a lot of dependencies.

Since I don't want to get too deep inside dependency hell, I was wondering what my best course of action here could be. Trying to install all the dependencies manually will probably result in an error somewhere even if I'm careful, as I'm dealing with kernel stuff here.

Any suggestions would be greatly appreciated.

share|improve this question
    
Couldn't you simply put a card that is compatible and be done with it. At some point it's about being practical I guess. –  Amphiteóth Sep 30 '13 at 23:54
    
Unfortunately the workstation is a mini-box and I couldn't practically get a compatible NIC that would also fit in such a short time frame. I could only find standard-size replacements. –  user991710 Oct 1 '13 at 0:41
    
To install packages with no connectivity, see Updates/applications/packages for Ubuntu 10.10 with no internet connection –  Gilles Oct 2 '13 at 0:18

2 Answers 2

Install a kernel from testing or unstable and pin it (see apt pinning for details).

share|improve this answer
    
I wouldn't recommend pinning testing/unstable on a stable box even for more advanced users. It's very easy to accidentally upgrade a core package such as libc6 from dependencies. –  jordanm Sep 30 '13 at 23:42

Debian Backports is the recommended way to get newer software on a stable Debian system.

Device drivers are a part of the kernel. Upgrading the kernel will also update the device drivers. Debian Backports provides version 3.10, which is the same version currently available in Debian Testing. Since you are without network, you can download the deb from another machine and transfer it via usb.

Here are links to the amd64 (64bit) and i386 (32bit) packages.

You can install these via dpkg -i. After successful installation, a reboot is required.

share|improve this answer
    
Thank you for your swift answer. I'm home now, but I'll try your suggestion first thing tomorrow and let you know how it goes. Should everything work fine, consider your answer accepted! –  user991710 Oct 1 '13 at 0:42
    
Addendum to the above: Should the above suggestion fail, what would you recommend (besides switching the NIC, as I can't practically do that here - see above comment reply)? –  user991710 Oct 1 '13 at 0:54
    
Unfortunately, this did not work. The backports package requires initramfs-tools >=0.110, which has a boatload of dependencies as well. Attempting to manually install them likely broke my current fresh install, as I can't seem to find a way for apt-get to look locally for packages (aside from making a local repo - something I can't do either without proper tools). I guess I'll try a USB network adapter and see if that helps... –  user991710 Oct 1 '13 at 16:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.