Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an Nvidia GTX260 video card and I'm using Ubuntu 12.04 x64 bit. I've been trying for hours to get StarCraft II to work with wine and PlayOnLinux. I have tried nearly everything under the sun to get drivers for it to work:

  1. Just using nouveau
  2. The .run package from nvidia's website
  3. sudo apt-get install nvidia-current
  4. This method which oddly enough is for 12.10 not 12.04
  5. sudo jockey-text -d xorg:nvidia_current

When I start PlayOnLinux it says: PlayOnLinux is unable to find 32bits OpenGL libraries. You might encounter problem with your games.. When I run StarCraft II, after hitting the play button in the launcher, it says: Failed to initialize DirectX. You may need to reinstall DirectX. If the problem persists....

Now I'm in a bit of a mess and I'm considering reinstalling Ubuntu to start fresh. x32 bit this time, since I don't have more than 4GB RAM, and it won't cause the bug mentioned below. However, is there any way to "reset" so to speak? I want to start fresh with the display driver. I don't really want to reinstall Ubuntu since I spent hours customizing it with themes and whatnot.

I'm aware of a bug with Ubuntu 12.04 LTS x64 bit and wine which causes StarCraft II to not work in some cases. I had StarCraft II working last night using method 4 but with major fps drop from what I get using the same machine with windows 7 x64 bit.

EDIT

I found a solution: www.benjaminwiedmann.net/fix-nouveau-driver-issues-on-ubuntu-12-04-install-nvidia-drivers.html ! I can now run StarCraft II, I'm just looking now to see if I still have the same fps issues as before.

share|improve this question
1  
Try installing ia32-libs, since PoL complained about that. –  Wutaz Sep 28 '13 at 22:45
    
It says it's already installed. –  Xzar Sep 28 '13 at 23:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.