Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I tried yaourt -Syu and got this error:

error: failed to prepare transaction (could not satisfy dependencies)

:: Starting full system upgrade...

:: nvidia: requires linux<3.11

how could I solve this problem?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Try with yaourt -Syyu. (or pacman -Syyu as root)

If not working, double check:

  • if the first mirror in your mirrorlist is up-to-date (you may want to swap it for another one)
  • if you're using the standard nvidia package (because it's dependencies should be linux<3.12 and linux>=3.11, not linux<3.11)
  • if your pacman.conf file is consistent (ie you don't have both [extra] and [testing] uncommented)
share|improve this answer
    
My bad on that point. (not a testing user, and forgot to rtfm that before writing) –  François Lecomte Sep 30 '13 at 10:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.