Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Linux version:

shell> cat /proc/version
Linux version 3.2.0-4-686-pae (debian-kernel@lists.debian.org) (gcc version 4.6.3 (Debian 4.6.3-14) ) #1 SMP Debian 3.2.46-1+deb7u1

Installing MySQL 5.6.14 32-bit.

I mostly followed the installation instructions from http://dev.mysql.com/doc/refman/5.6/en/unix-postinstallation.html:

shell> dpkg -i /home/user/mysql-5.6.14-debian6.0-i686.deb
shell> groupadd mysql
shell> useradd -r -g mysql mysql
shell> cd /usr/local
shell> ln -s  /opt/mysql/server-5.6/mysql
shell> cd mysql
shell> chown -R mysql .
shell> chgrp -R mysql .

When I run the installation script:

shell> scripts/mysql_install_db --user=mysql --basedir=/usr/local/mysql --datadir=/var/lib/mysql

I get this Error:

Installing MySQL system tables...2013-09-26 11:14:20 0 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
2013-09-26 11:14:20 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2013-09-26 11:14:20 24642 [ERROR] Can't find messagefile '/usr/share/mysql/errmsg.sys'
2013-09-26 11:14:20 24642 [Note] InnoDB: The InnoDB memory heap is disabled
2013-09-26 11:14:20 24642 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2013-09-26 11:14:20 24642 [Note] InnoDB: Compressed tables use zlib 1.2.3
2013-09-26 11:14:20 24642 [Note] InnoDB: Using Linux native AIO
2013-09-26 11:14:20 24642 [Note] InnoDB: Not using CPU crc32 instructions
2013-09-26 11:14:20 24642 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2013-09-26 11:14:20 24642 [Note] InnoDB: Completed initialization of buffer pool
2013-09-26 11:14:20 24642 [Note] InnoDB: The first specified data file ./ibdata1 did not exist: a new database to be created!
2013-09-26 11:14:20 24642 [Note] InnoDB: Setting file ./ibdata1 size to 12 MB
2013-09-26 11:14:20 24642 [Note] InnoDB: Database physically writes the file full: wait...
2013-09-26 11:14:20 24642 [Note] InnoDB: Setting log file ./ib_logfile101 size to 48 MB
2013-09-26 11:14:21 24642 [Note] InnoDB: Setting log file ./ib_logfile1 size to 48 MB
2013-09-26 11:14:21 24642 [Note] InnoDB: Renaming log file ./ib_logfile101 to ./ib_logfile0
2013-09-26 11:14:21 24642 [Warning] InnoDB: New log files created, LSN=45781
2013-09-26 11:14:21 24642 [Note] InnoDB: Doublewrite buffer not found: creating new
2013-09-26 11:14:21 24642 [Note] InnoDB: Doublewrite buffer created
2013-09-26 11:14:21 24642 [Note] InnoDB: 128 rollback segment(s) are active.
2013-09-26 11:14:21 24642 [Warning] InnoDB: Creating foreign key constraint system tables.
2013-09-26 11:14:21 24642 [Note] InnoDB: Foreign key constraint system tables created
2013-09-26 11:14:21 24642 [Note] InnoDB: Creating tablespace and datafile system tables.
2013-09-26 11:14:21 24642 [Note] InnoDB: Tablespace and datafile system tables created.
2013-09-26 11:14:21 24642 [Note] InnoDB: Waiting for purge to start
2013-09-26 11:14:21 24642 [Note] InnoDB: 5.6.14 started; log sequence number 0
2013-09-26 11:14:21 24642 [ERROR] Aborting

2013-09-26 11:14:21 24642 [Note] Binlog end
2013-09-26 11:14:21 24642 [Note] InnoDB: FTS optimize thread exiting.
2013-09-26 11:14:21 24642 [Note] InnoDB: Starting shutdown...
2013-09-26 11:14:23 24642 [Note] InnoDB: Shutdown completed; log sequence number 1600607
2013-09-26 11:14:23 24642 [Note]

I've tried touch /usr/share/mysql/errmsg.sys with mysql ownership but that doesn't change anything.

I can see that it is writing something to /var/lib/mysql

shell> ll /var/lib/mysql
total 110600
-rw-rw---- 1 mysql mysql 12582912 Sep 26 11:14 ibdata1
-rw-rw---- 1 mysql mysql 50331648 Sep 26 11:14 ib_logfile0
-rw-rw---- 1 mysql mysql 50331648 Sep 26 11:14 ib_logfile1
drwx------ 2 mysql mysql     4096 Sep 26 11:14 mysql
drwx------ 2 mysql mysql     4096 Sep 26 11:14 test

When I try:

shell> bin/mysqld_safe --user=mysql &

I get the exact same error output.

I just dunno. Thanks for the help in advance.

share|improve this question
1  
Why aren't you using the mysql-server package that is provided by Debian? It's probably easier to install and to use, and you won't have to bother with manually installing updates. –  Martin von Wittich Sep 26 '13 at 17:03
    
You are right. I could and I can. However I want to match the version on my dev box to the production version. –  shrimpwagon Sep 26 '13 at 17:07
1  
It's possible that there's a my.cnf somewhere in your home or in /etc that points mysql to the wrong location (/usr/share/... instead of /usr/local/...) for its share files. Try to add the parameter --no-defaults to your mysql_install_db command line. Source –  Martin von Wittich Sep 26 '13 at 17:17
    
Yeah, I think your're right. I downloaded 5.7.2-m12, I deleted everything in /etc/mysql, re-ran mysqld_install_db and everything works now. Not sure if it was going to 5.7 that did it or deleting /etc/mysql contents but your're probably right. –  shrimpwagon Sep 26 '13 at 18:14
1  
OK. I re-posted my comment as an answer so you can mark it as accepted to close the question. –  Martin von Wittich Sep 26 '13 at 18:44
show 2 more comments

1 Answer 1

up vote 2 down vote accepted

From the comments:

It's possible that there's a my.cnf somewhere in your home or in /etc that points mysql to the wrong location (/usr/share/... instead of /usr/local/...) for its share files. Try to add the parameter --no-defaults to your mysql_install_db command line. Source

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.