Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an issue with HDMI sound.

I recently upgraded to Fedora 19 (clean install) but this issue exsists on F18 too. I have Intel DQ67SW motherboard with integrated audio/video and ASUS-NVidia GT220 VGA card. Both the MB and the VGA have HDMI output but Phonon will only find the first HDMI on the MB regardless of it is used or not. I have only one Monitor with speakers and of course it’s connected to the VGA card.

I use Fedora 19 with KDE.

Strange thing that when I switch to Gnome the sound will work. If I switch back, KDE will also work but the sound configuration UI won’t list the proper device in the selection. If I change the selection the sound will fail immediatel on the change, even if I click on Cancel.

Now I have to install Gnome to manage the sound settings only!

As far as I see it’s user specific configuration and located somewhere in the home directory. I tried to save various sound related files (e.g. pulse, libphonon.something), but none of them helped.

Can anybody explain me this behavior?

I red about that Phonon has issues with multiple HDMI outputs but it's somehow forcible to have a secondary one.

I want to have a proper workaround (without Gnome) with which I can control the sound settings.

I used to configure asound.conf even with plugs and redirections but couple of kernel updates ago it won’t work. And AFAIK KDE use Pulseaudio, not Alsa.

I didn’t mentioned that before one of the kernel updates I didn’t have any sound issues. I can’t remember the exact version.

share|improve this question
add comment

1 Answer

Put this in your /etc/asound.conf

pcm.softvolPhonon {
 type softvol
 slave.pcm "default:CARD=0"
 control {
     name "HDMI"
     card 0
 }
 min_dB -51.0
 max_dB 0.0
 resolution 100
 hint {
     show on
     description "hdmi with extra Volume Control"
 }
}

You need to replace card 0 with the hdmi audio output in you system.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.