Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am installing QEMU in RHEL. In 32 bit OS (i686 architecture), if I run the command, yum install qemu, the installation of QEMU takes place. However, in 64 bit architecture (x86_64), if I run the same command, I am getting the error as "QEMU package not available". Is the yum installation dependent on the architecture of the OS version?

EDIT:

This is the output of yum list |grep qemu

qemu.i386 2:0.10.5-1.el5.2 installed
qemu-common.i386 2:0.10.5-1.el5.2 installed
qemu-img.i386 2:0.10.5-1.el5.2 installed
qemu-system-arm.i386 2:0.10.5-1.el5.2 installed
qemu-system-cris.i386 2:0.10.5-1.el5.2 installed
qemu-system-m68k.i386 2:0.10.5-1.el5.2 installed
qemu-system-mips.i386 2:0.10.5-1.el5.2 installed
qemu-system-ppc.i386 2:0.10.5-1.el5.2 installed
qemu-system-sh4.i386 2:0.10.5-1.el5.2 installed
qemu-system-sparc.i386 2:0.10.5-1.el5.2 installed
qemu-system-x86.i386 2:0.10.5-1.el5.2 installed
qemu-user.i386 2:0.10.5-1.el5.2 installed

share|improve this question
    
On my RHEL 6 systems, I can install qemu-kvm and get the userspace QEMU tools. I don't see any qemu packages available for either 32 or 64 bit. Where is your qemu package coming from in 32-bit land? –  John Sep 23 '13 at 18:14
    
I have a system with i686 architecture. If I run "yum install qemu" I am getting the qemu for i386 architecture. I am confused on why this is happening in i686 architecture but not on x86_64 systems? –  Ramesh Sep 23 '13 at 18:18
    
What is the output of yum list | grep qemu on your i686 box? –  John Sep 23 '13 at 18:28
    
I have updated the question with the output of the command. –  Ramesh Sep 23 '13 at 18:55
1  
These are RHEL 5 packages, which don't come from Red Hat repositories. Where did you get these packages? (yum install doesn't count - what repository did they come from?) –  John Sep 23 '13 at 18:56

1 Answer 1

up vote 2 down vote accepted

Your 64 bit system does not have the appropriate external repository defined for the 64-bit QEMU packages. You will need to find a repository with these packages available and install the appropriate .repo file in /etc/yum.repos.d/ before you can yum install the QEMU packages. A quick Google search shows that RepoForge has 64-bit QEMU packages available, so that would be a good starting point.

share|improve this answer
    
Thanks! That makes real sense. I found that the repo file is missing in the 64 bit machine. Will update the repo file first and then do the yum install. –  Ramesh Sep 23 '13 at 19:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.