Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to install SimpleScreenRecorder (SSR) from git as recommended by the developer. The binary version crashes while the git version fixes my crash problem. Unfortunately, to build the git version I have to resort to a work-around -- and now I've run into side effects from that.

Main page - SimpleScreenRecorder - Maarten Baert's website

The instructions are found here: https://github.com/MaartenBaert/ssr

The dev says, "I don't know whether this is the right way to do it, but it works for me."

It worked for me too, but it is not nice in situations such as changing video drivers (which I'm doing now).

Therefore, I decided to come ask the experts here for a better solution. I'm hoping someone knows the right way to resolve this.

(BTW, I asked a similar but different question and answered it myself here: http://askubuntu.com/a/347620/36661) I'm running Kubuntu 12.04 with the lts-raring hardware enablement stack.

The problem is that the 64-bit portion of the build works, but the 32-bit portion fails due to some libraries missing. The proposed workaround involves manually creating symlinks to make up for the "missing" libraries. Here are my build/install steps including the workaround symlink creation:

sudo apt-get install build-essential pkg-config qt4-qmake libqt4-dev libavformat-dev libavcodec-dev libavutil-dev libswscale-dev libasound2-dev libpulse-dev libgl1-mesa-dev libx11-dev libxext-dev libxfixes-dev g++-multilib ia32-libs
cd /workspaces/ (or any path you choose - see note below)
git clone https://github.com/MaartenBaert/ssr.git (in my case the project path is /workspaces/ssr/)
sudo mkdir /usr/lib32/fglrx/
cd /usr/lib/i386-linux-gnu/
sudo ln -s libGL.so.1 /usr/lib32/fglrx/libGL.so  # only for proprietary AMD drivers!
# SKIP: sudo ln -s fglrx/libGL.so /usr/lib32/libGL.so    # only for proprietary AMD drivers!
sudo ln -s libGLU.so.1 libGLU.so
sudo ln -s libX11.so.6 libX11.so
sudo ln -s libXext.so.6 libXext.so
sudo ln -s libXfixes.so.3 libXfixes.so
sudo ldconfig
cd /path/to/ssr (will be the ssr directory under `/workspaces/` in my example)
$ ./simple-build-and-install 

So, what's the right way to solve the problem so that I don't have to create these symlinks and so that the app won't break if I change video drivers?

Is there an IRC channel that is appropriate for this question?

share|improve this question
    
Why not install the 32-bit versions of the libraries? –  slm Sep 21 '13 at 3:56
    
@slm - I was just reading this: unix.stackexchange.com/a/47003/15010. Can you tell what which 32-bit packages I need to install based on the symlinks in the workaround? –  MountainX Sep 21 '13 at 4:07
    
I should also mention that I need to use libgl1-mesa-dev-lts-raring instead of libgl1-mesa-dev. –  MountainX Sep 21 '13 at 4:09
    
So far, no luck... I tried apt-get install libx11-dev:386 but there is no such package. (It was just a guess on my part anyway.) –  MountainX Sep 21 '13 at 4:15
    
Try :i386 instead. –  slm Sep 21 '13 at 4:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.