Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

We are setting up a lab which has the QEMU system to emulate an ARM processor and run assembly programs. The lab is currently setup with the host operating system as Ubuntu. We are migrating the lab to RHEL environment. We are going to use RHEL 5.6 version OS. These are the set of software that needs to be installed to make the lab up and running.

  • QEMU Emulator - It was fairly straight-forward. I used the command yum install qemu and yum install qemu-kvm for the virtualization.
  • GCC for ARM - I am actually stuck in this process. I downloaded the gcc arm from this link. I used the command, tar xjvf gcc-arm-none-eabi-4_7-2013q1-20130313-linux.tar.bz2 to extract the file and install it. However, after installation if I run the command,arm-none-eabi-gcc --version it is not giving me the version but an error saying command not found.
  • GDB communicating with the QEMU/ARM program being executed.

What am doing wrong in the installation process?

EDIT:

The contents of the tar ball after extraction are as below. There are 5 folders named,

  • arm-none-eabi
  • bin
  • gcc- arm-none-eabi-4_7-2013q2
  • lib
  • share
share|improve this question
add comment

1 Answer

I can't tell for certain given the information you posted, but it looks like the gcc tar.bz2 file you downloaded is a source tarball, which you have to run configure; make; make install against.

share|improve this answer
    
ok..I do not see any configuration file inside the extracted folder. Does that mean, I will not be able to install it? I ran the commands, ./configure, make and make install..None of them worked.. –  Ramesh Sep 20 '13 at 19:00
    
Can you edit your post and show the contents of the tarball? –  John Sep 20 '13 at 19:04
    
I have made the edit with the contents of the tar ball.. –  Ramesh Sep 20 '13 at 19:10
    
Ok, I was wrong - it's not a source tarball. Did you add the unrolled bin directory's full path to your shell's PATH? Or did you use the full pathname when trying to execute arm-none-eabi-gcc ? –  John Sep 20 '13 at 19:13
    
Yeah. I set the path using the command as given in the tutorial in the link that I provided. The command that I used is, export PATH=$PATH:/opt/ARM/gcc-arm-none-eabi-*/bin –  Ramesh Sep 20 '13 at 19:15
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.