Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've installed VirtualBox (and it's Guest Additions), and after updating the kernel to the latest and also updating VB accordingly, I can not boot normally . (X server doesn't start, but I can login using Ctrl+Alt+F2)

I read in the last post here that the problem is probably caused by graphical parts (OpenGL hardware 3D acceleration) of this Guest Addition.

Is there any way to fix the problem without reinstalling Fedora ?

share|improve this question
    
How did you update VB and what graphics card/driver do you have? –  schaiba Sep 20 '13 at 14:47
    
@schaiba After updating linux kernel, you have to run a command to update VB to make it work on the new kernel. GraphicsCard: CPU's built-in Intel HD Graphics. –  Zorich Sep 20 '13 at 16:15
add comment

1 Answer

you can do two things:

1.The first is to disabled 3D acceleration on the vm until it gets fixed.

  1. What does the logs for the X server say? if X does not boot there will be a reason there, you can try to debug and maybe go further.
share|improve this answer
    
Thanks. But how can I do that? (the first one) –  Zorich Sep 21 '13 at 21:15
    
check VM settings in vbox for the display. disable 3d acceleration –  BitsOfNix Sep 22 '13 at 20:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.