Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

tl;dr After reading the Arch wiki articles on installation, wireless setup and WPA supplicant, trying the suggestions below and a host of forum threads, I'm unable to get either of the following cards to connect to my wireless network when booting the Arch Linux 2013-09-01 ISO:


Approach 1 (default):

The default way of doing this is supposed to be just systemctl stop dhcpcd.service followed by wifi-menu. It finds the network:

[SSID] + wpa 10

After a timeout it reports that the connection failed. If I run wifi-menu a second time it doesn't ask for a password, but when finished it finally gives some debug hints:

Job for netctl@wlp0s29f7u5\x2dBTHub4\x2dGRK6.service failed. See 'systemctl status netctl@wlp0s29f7u5\x2dBTHub4\x2dGRK6.service' and 'journalctl -xn' for details.

The former reports that the service is "loaded" but not "active" (literally inactive (dead)). The latter says:

WPA association/authentication failed for interface 'wlp0s29f7u5'

Does this mean the key in /etc/netctl/wlp0s29f7u5-BTHub4-GRK6 is wrong? I can't tell when programs want the actual Wi-Fi password and when they want something like the psk value from wpa_passphrase (man 5 netctl.profile doesn't say, for example).


Approach 2 (wpa_supplicant and wpa_passphrase as per deeraf and warl0ck's suggestions and the wiki page):

# echo 'ctrl_interface=/var/run/wpa_supplicant' > wifi.conf
# wpa_passphrase essid passphrase >> wifi.conf
# wpa_supplicant -B -i interface -c wifi.conf
Successfully initialized wpa_supplicant
# dhcpcd -A interface
[...]
timed out
exited

I tried connecting with iw directly, but got some strange output:

# iw dev wlp0s26f7u5 connect [SSID]
command failed: Operation not supported (-95)
share|improve this question
    
Have you tried to test the stick with a different distro, for example an Ubuntu live system, just to establish that it works in Linux? Is there something interesting in your dmesg output, maybe something that's pointing to a firmware issue? –  Martin von Wittich Sep 27 '13 at 20:25
    
Interestingly, on Ubuntu 13.04 it shows up on the networking menu, but is displayed as "Disconnected". –  l0b0 Sep 27 '13 at 20:56
    
So you can't connect on Ubuntu either? Have you considered just using another WiFi USB stick? That may be an easier solution to your problem. –  Martin von Wittich Sep 27 '13 at 20:58
    
I guess. The latest driver only supports kernels up to 2.6.33. Too bad it's almost impossible to find trustworthy sources of Linux compatible hardware. –  l0b0 Sep 27 '13 at 21:20
1  
I usually use dhcpcd -d -n interface - it gives you more information. Also it is a good idea to check the state of the interface with iwconfig first. Ideally 1) run wpa_supplicant in a separate terminal without the -B option, but with -d to get more debugging info, i.e.: wpa_supplicant -d -i interface -c wifi.conf -Dwext ; 2) in another terminal, check iwconfig; 3) in another terminal run. Alternatively, before all this you might want to give wicd a try. –  peterph Oct 8 '13 at 7:04
show 13 more comments

3 Answers 3

Did you setup your passphrase with wpa_passphrase? e.g

%> wpa_passphrase SSID passphrase
network={
        ssid="SSID"
        #psk="passphrase"
        psk=28964ba6ea8b8f3a0db1c4414b327da253d0af5d4f4adccec0f8abf5b05b10f8
}

Otherwise wpa_supplicant -B -i [wireless device] -c /etc/wpa_supplicant/cli.conf won't work at all

share|improve this answer
    
Interesting. Do you have to hash the password, or put it in as quoted/unquoted plaintext? –  l0b0 Sep 30 '13 at 14:37
    
@l0b0 it was all generated by wpa_passphrase, no, only hashed version is required –  warl0ck Sep 30 '13 at 15:37
    
So I need to copy that string manually to wpa_cli? Isn't there an easier way to do this? It seems I'm connected afterwards (at least there are no error messages), so I'll award this answer. –  l0b0 Oct 4 '13 at 18:11
    
@l0b0 I've never thought about wpa_cli before. Normally I'd run wpa_supplicant directly (remember specify the wireless interface and the driver) with the generated config file. Then I check the output of dmesg to see if it's associated –  warl0ck Oct 5 '13 at 6:36
    
According to the wpa_supplicant.conf the psk option seems to be the unhashed key. And you should have a key management specification, like: key_mgmt=WPA-PSK as well. –  peterph Oct 8 '13 at 7:07
add comment

wifi-menu should set up your passphrase for you. There shouldn't be a need to set it up manually. Check the configuration for wlp0s29f7u5 in /etc/conf.d/network-wireless@. Also check /etc/wpa_supplicant.conf to see if the information is correct.

Another thing, unless you are trying to set up a static address you shouldn't need to stop the dhcpcd service. If it is static then make sure you declare that in /etc/conf.d/network-wireless@

Finally provide and ip. 'dhcpcd wlp0s26f7u5' for dhcp

or for static do the following.

ip addr add "your ip"/24 dev wlp0s26f7u5 ip route add default via

EDIT

The file I was trying to refer to is in netctl. Here is mine:

[verdict@sparky ~]$ cat /etc/netctl/wlo1-ZombieNet 
Description='Automatically generated profile by wifi-menu'
Interface=wlo1
Connection=wireless
Security=wpa
ESSID=ZombieNet
IP=dhcp
Key=<my password>
share|improve this answer
    
And btw I don't use the /etc/wpa_supplicant/wpa_supplicant.conf file at all. You don't have to with wifi-menu. –  Jeight Oct 10 '13 at 2:07
    
I have verified the password in wifi-menu, the generated file and the wpa_passphrase output file multiple times to no avail. The same password works on another (Ubuntu) machine, so that is not the issue. –  l0b0 Oct 11 '13 at 11:26
add comment
up vote 0 down vote accepted

It seems like the main problem is the BT Home Hub version 4 which came with the Internet subscription. After disabling 5 GHz wireless, WPS, 802.11 n, automatic channel selection and setting security to WPA2 only, I'm now able to get a connection within seconds in both Ubuntu and Windows, and a very sketchy connection (as in, ~30 seconds connectivity every few minutes with wpa_supplicant) with an up-to-date Arch Linux.

Update: After using NetworkManager (nmcli dev wifi connect SSID password PASSWORD) I am getting what seems like a little more stability - it still drops out every few minutes or so.

Windows also does not always get a connection for several minutes, after which it seems stable.

(I also tried connecting an old ADSL router, not realising that it cannot understand a VDSL signal.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.