Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm having a really hard time getting Mint13 installed on my new laptop, no optical UEFI support and having odd corruption of grub.cfg when I do try and use unetbootin.

Is there a method to build a UEFI bootable USB drive that I can place the Mint13 iso on?

Is below sane sounding?

$ sudo mount /dev/sdb1 /mnt
$ sudo mkdir /mnt/boot
$ sudo mkdir /mnt/boot/efi
$ sudo grub-install --boot-directory=/mnt
$ sudo mkdir /mnt/iso/
$ sudo mkdir /mnt/boot/grub/scripts

Save autoiso.cfg script in the /mnt/boot/grub/scripts

Then echo 'configfile /boot/grub/scripts/autoiso.cfg' >> /mnt/boot/grub/grub.cfg
share|improve this question
    
Have you tried any of the tools recommended on pendrivelinux.com? They will make this much less painful. –  terdon Sep 16 '13 at 1:28
    
Yea I tried that. It couldn't find an OS on the drive, even though it did come up. –  Bob R Sep 16 '13 at 5:08
    
Did you try some of the unetbootin alternatives they link to? I seem to recall having similar problems with a Mint install (might have been LMDE) and the same machine booted fine from a USB created by multisystem. –  terdon Sep 16 '13 at 5:15

1 Answer 1

I got this working by getting on a friends windows machine, and using rufus, and selecting the "MBR Partition Scheme for UEFI or BIOS Computers" and it booted up showing the UEFI prefix on the flash drive.

Odd that it didn't see it with just GPT and UEFI.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.