Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using CentOS 6.4 and I was following this tutorial in order to upgrade PHP from v 5.3.3 to v 5.4.19 but I got the following error:

Error: php54w-common conflicts with php-common-5.3.3-23.el6_4.i686

. How do I resolve this problem?

[my_profile@localhost gplus-quickstart-php]$ sudo rpm -Uvh http://mirror.webtatic.com/yum/el6/latest.rpm                                                           
[sudo] password for my_profile:                                                    
Retrieving http://mirror.webtatic.com/yum/el6/latest.rpm                        
warning: /var/tmp/rpm-tmp.S0yqSL: Header V4 DSA/SHA1 Signature, key ID cf4c4ff9: NOKEY                                                                          
Preparing...                ########################################### [100%]  
   1:webtatic-release       ########################################### [100%]  
[my_profile@localhost gplus-quickstart-php]$ sudo yum install php54w
Loaded plugins: fastestmirror, refresh-packagekit, security      
Loading mirror speeds from cached hostfile                       
 * base: mirror.netglobalis.net                                  
 * extras: mirror.netglobalis.net                                
 * rpmforge: mirror.nexcess.net                                  
 * updates: mirror.netglobalis.net                               
 * webtatic: us-east.repo.webtatic.com                           
webtatic                                                 | 2.9 kB     00:00     
webtatic/primary_db                                      |  98 kB     00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php54w.i386 0:5.4.19-1.w6 will be installed
--> Processing Dependency: php54w-common = 5.4.19-1.w6 for package: php54w-5.4.19-1.w6.i386
--> Processing Dependency: php54w-cli = 5.4.19-1.w6 for package: php54w-5.4.19-1.w6.i386
--> Running transaction check
---> Package php54w-cli.i386 0:5.4.19-1.w6 will be installed
---> Package php54w-common.i386 0:5.4.19-1.w6 will be installed
--> Processing Conflict: php54w-common-5.4.19-1.w6.i386 conflicts php-common < 5.4.0
--> Finished Dependency Resolution
Error: php54w-common conflicts with php-common-5.3.3-23.el6_4.i686
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[my_profile@localhost gplus-quickstart-php]$ ^C
[my_profile@localhost gplus-quickstart-php]$ ^C
[my_profile@localhost gplus-quickstart-php]$ Error: php54w-common conflicts with php-common-5.3.3-23.el6_4.i686
bash: Error:: command not found
[my_profile@localhost gplus-quickstart-php]$
share|improve this question

1 Answer 1

up vote 2 down vote accepted

The tutorial you cited does recommend using this Webtatic repo on a fresh system, where you can avoid conflicts with installed packages, but suggests that you can upgrade a currently-installed php using (as root or with sudo):

yum install yum-plugin-replace
yum replace php-common --replace-with=php54w-common

Then try sudo yum install php54w again.

share|improve this answer
    
+1 Thank you so very much for your helpful reply. Your solution worked! I probably did not read the tutorial properly but I really appreciate your help. Thanks again! –  Anthony Sep 16 '13 at 1:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.