Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My wireless connection is frequently terminated (reason unknown). I can remedy the problem either by rebooting or by unloading and reloading the kernel module for my wireless network interface controller (Intel Corporation Centrino Wireless-N 1000 [Condor Peak]).

The frequency with which the connection terminates appears to be random, so unloading and reloading the kernel once per minute (cron: */1 * * * * modprobe -r iwlagn; modprobe iwlagn; iwconfig) usually provides uninterrupted connectivity for a period of a few hours.

If I recall correctly, this problem occurred shortly after upgrading to multiarch support in Debian 7. Please advise if you know or can suggest a solution.

share|improve this question

1 Answer 1

I believe this is a known issue with the N 1000 cards. I have one in my laptop that has been plagued by this issue since day one. What we ended up doing was disabling the N side of this card since that is where the issue was isolated by myself and others.

This blog post extensively covered the issue, titled:

You can disable wireless N functionality temporarily like so:

$ modprobe iwlagn 11n_disable=1

To make it permanent:

# /etc/modprobe.d/wireless.conf
options iwlagn 11n_disable=1

then unload and reload the driver:

# unload
$ rmmod iwlagn

# load
$ modprobe iwlagn

Latest Intel Drivers

You can try downloading and installing the latest Centrino drivers for the N-1000 cards from here, Wireless Networking + Intel® Wi-Fi Products + Intel® Centrino® Wireless.

share|improve this answer
    
Thanks for the information. I will try disabling 802.11N for a day or so to confirm that the network termination problem has resolved. –  user001 Sep 14 '13 at 23:55
    
Implementing these steps seems to help somewhat, but the connection still terminates periodically, requiring manual reactivation using the commands specified in the original post. –  user001 Sep 18 '13 at 1:18
    
@user001 - if you have control over the access point you might want to try disabling wireless-N there as well. –  slm Sep 18 '13 at 1:21
    
Thanks, unfortunately the access point is in a work environment, and I do not have control over it. –  user001 Sep 19 '13 at 21:54
    
@user001 - if you're totally desperate you can try getting the latest Intel drivers, downloadcenter.intel.com/…. Added this to the answer too! –  slm Sep 19 '13 at 21:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.