Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I recently installed CUPS 1.5.3 on my Debian Squeeze server. I don't think it's relevant but I think the latest version is 1.6.3, right? However, I'm installing with aptitude, so I'm getting this apparently older version.

So my problem is:

  • I configure 1 LPD printer
  • I sent a job with printer door/cover opened, so is not printed right?

But the job stays in the queue with Spooling job, 0% complete for infinite minutes.

So, I want to limit this time, for cups alter status to error (or any other), because, if I can change it, and limit the timeout, maybe with some script, I can redirect this job to another printer.

How can I do that?

share|improve this question

1 Answer 1

The only timeout that I noticed in looking through the CUPS documentation that sounded possibly relevant is the option named, Timeout. It defaults to 5 minutes (300 seconds) but you can change it to something shorter and see what happens.

Timeout 30

Be sure to restart CUPS after making any changes to this file.

share|improve this answer
    
Ok, a set the timeout but it didn't work. –  Patrick Maciel Sep 13 '13 at 18:44
    
@PatrickMaciel-p4dev - was afraid you'd say that. 8-). I'd scroll through the list of other timeout named options and try those as well. –  slm Sep 13 '13 at 18:45
    
I set Timeout = 3. But status keep spooling 0% –  Patrick Maciel Sep 13 '13 at 18:47
    
Ok. You know if cups is the better choice for print managment? –  Patrick Maciel Sep 13 '13 at 18:48
    
I'll test the ReloadTimeout –  Patrick Maciel Sep 13 '13 at 18:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.