Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I remove unity and gnome 3 in my Ubuntu. I am using now just mate desktop. But I would like to restore Unity and Gnome3.

So I tried this re-install solution, but now i get:

The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libunity-core-6.0-dev : Depends: libglib2.0-dev but it is not going to be installed
                         Depends: libnux-4.0-dev (>= 4.0.0) but it is not going to be installed
                         Depends: libunity-dev (>= 4.0.0~) but it is not going to be installed
                         Depends: libdee-dev but it is not going to be installed
 nautilus : Depends: nautilus-data (< 1:3.7) but 1:3.8.2-0ubuntu1~ubuntu13.04.1 is to be installed
 nautilus-sendto-empathy : Depends: empathy (= 3.6.4-0ubuntu4.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

What can I do to resolve this?

EDIT: I already tried apt-get install -f but there is no list to repeare

share|improve this question
    
I try also with sudo aptitude install libglib2.0-dev –  senzacionale Sep 13 '13 at 8:53

1 Answer 1

if you have problem for package installation use apt-get install -f , APT system itself repair your problem. of course if you have lack of package dependency or half installed.

share|improve this answer
    
I already tried apt-get install -f but there is no list to repeare. –  senzacionale Sep 13 '13 at 6:34
    
So problem is not you and your machine, probelem from server side.Of course if you fill /etc/apt/sources.list correctly –  Mohsen Pahlevanzadeh Sep 13 '13 at 18:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.