Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I installed Debian 6.0 (squeeze) a few days ago on my machine. I installed the default GNOME desktop, standard settings. Unfortunately, I just noticed that when I plug in USB storage devices (external hard drivers, USB sticks, etc.), they don't get automatically mounted, like they used to (and presumably still should).

I noticed that the usb-storage module wasn't loaded automatically, either, so no device nodes were getting created either. So, I loaded that module, so at least now the device nodes get created automatically, it's just a case of mounting them manually. But that's not the point!

In nautilus's preferences, I have "Browse media when inserted" checked, (i.e., the default), but just nothing in the UI happens when I insert something. The device never appears in the Computer view.

Watching the kernel logs shows that the insertions are definitely being registered, and after manually loading usb-storage first (what is that about? Why isn't that happening automatically?), device nodes get created, but that's it.

So. My question is, from here, how do I go about finding out what's wrong?

share|improve this question
    
Is there anything strange in /etc/fstab? –  Tshepang Mar 11 '11 at 5:05

2 Answers 2

up vote 2 down vote accepted

I've fixed this now.

Firstly, I didn't install squeeze with the default GNOME desktop environment. I mis-remembered. What I did was install the base system, and then install the gnome-desktop-environment package, aiming for a lighter/closer-to-upstream set of packages.

Now, completely unscientifically, I did two things in one go to fix this, so I don't know for sure which did it. I decided to install Debian's GNOME desktop task (tasksel install gnome-desktop --new-install). I thought that maybe, somehow, gnome-desktop-environment didn't pull in the right packages to enable this functionality. In retrospect, I think that's unlikely.

Next, I restarted the machine. I was sure I had restarted the machine after installing gnome-desktop-environment, but now I think I hadn't. So presumably, some services weren't working properly, or something like that.

After restarting, things worked exactly as I wanted - USB storage devices were being mounted automatically, at /media/, which is great.

share|improve this answer
1  
The gnome-disk-utility package and its dependencies seem to be what handles this, but if you have the gnome-desktop-environment package installed you should already have gnome-disk-utility. –  Arrowmaster Mar 11 '11 at 17:29

Run gconf-editor and check the mark against "/desktop/gnome/volume_manager/automount_drives"

It should do the work.

share|improve this answer
    
I thought autofs was required for automounting. autofs5 seems like the current version in Debian squeeze. Do the desktop environments have their own automount functionality? What about KDE? I'd be interested to see documentation for desktop environments about this. –  Faheem Mitha Mar 11 '11 at 6:44
    
I don't think that key exists in squeeze, because it belongs to the package gnome-volume-manager, which isn't actually installed by default. I believe some other package/mechanism handles volumes. GNOME have reworked all of that stuff quite heavily over the last few years ;o –  markrian Mar 11 '11 at 12:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.