Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to use bmake to build OS161 on Mandriva. When I try to run bmake, I get the following error:

bmake: no system rules (sys.mk)

I get the same error, even when I run

bmake -m /usr/local/share/mk/sys.mk

I've checked, and the path I listed above exists, but regardless of what path I give it, even if I give it a garbage path, I get the same error.

This happens no matter what directory I run bmake in, so it's definitely not an OS161 problem. Does anybody know how to fix this?

share|improve this question

1 Answer 1

The -m option takes a directory name, not a filename.

bmake -m /usr/local/share/mk

Otherwise, your version of bmake doesn't match the version of the mk files in /usr/local/share/mk.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.