Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using Windows8 as my host OS, and are running a Linux Mint VM on virtualbox, with its network being virtualized as NAT. I'm using Ciscos AnyConnect VPN to get access to a certain network. The Cisco anyConnect is run from my host OS(Windows). When I run AnyConnect at the host-os, the VM is able to connect to the vpn-network as well.

However, when I run AnyConnect at windows, the DNS lookup of the Linux Mint VM stops working. (It's internet connection otherwise is fine).

/etc/resolv.conf looks identical both when the DNS fails(vpn connected on windows-host), and when DNS works correctly(vpn is disconnected on windows-host).

Any clue why and how to fix it?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.