Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a usability problem with the "Open file" dialog.

The questions would be:

  • Is there any way out? E.g. can I disable the autocomplete?
    Otherwise, I might post a bug report..
  • Why does this happen?
    Which package / component is responsible for this dialog?
    (so I know where to report it)

Details:

I'm on LMDE (Linux Mint Debian Edition) with Cinnamon. The problem happens in the "Open file" dialog i get in GEdit, Chromium, etc.
I don't know which exact package is responsible for the Open file dialog - Cinnamon, Gnome, Nemo or something else. Maybe someone could confirm if this happens in other distros / desktops.
Thus, I also don't know if this is better suited for unix.stackexchange or for askubuntu.

Steps to reproduce:

  • Hit Ctrl+O in an application (browser, gedit, other) to open the "Open file" dialog.
    -> The dialog contains a file browser area, and at the top, a text field for file name / path.
    -> focus is on the text field.
  • Click into the file browser area
    -> this will set the focus on the file browser area
  • Start typing
    -> this will search in the list of files in the file browser area
  • Hit the up/down arrow keys
    -> this will move the current selection up and down in the file browser area
  • When a directory is selected, hit Enter
    -> this will let the dialog dive into that folder.
    -> PROBLEM: Now the focus is back on the text field!
    -> A dropdown with autocomplete suggestions appears.
  • Start typing.
    -> this will type in the text field, instead of searching in the file browser
  • Hit TAB.
    -> this will select an autocomplete option, instead of jumping to the file browser
  • Hit the down arrow key.
    -> This will go down into the autocomplete dropdown, instead of to the file browser area.

This is all quite painful to me. I like to focus on the file browser area, but the dialog won't let me :(

share|improve this question

1 Answer 1

I had this problem as well with Mint 16 Cinnamon and Mint 17 Debian Cinnamon.

There's a pencil icon (top left most one) in the open file dialog. This toggles the location bar. If it's off, you'll never lose focus of the browser area.

Not sure if there is a way to have the location bar be there, and still have default focus on the browser area.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.