Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm dual-booting an old MacBook Pro with OS X 10.5 and Ubuntu Studio 13.04. I've partitioned my internal SATA drive as follows:

/dev/sda1: LABEL="EFI" UUID="3F3C-1AF6" TYPE="vfat" (EFI Boot Partition)
/dev/sda2: UUID="b5ad14bd-a515-3227-a77a-3dfc75a9a771" LABEL="MacKael" TYPE="hfsplus" (OS X Partition)
/dev/sda3: LABEL="Ritz-MacLinux" UUID="239fd22b-f7c0-4485-ac0c-628501642561" TYPE="ext4" (Ubuntu Partition)
/dev/sda4: UUID="f5c8b700-b743-42a1-bae3-43fb361d26a7" TYPE="swap" 
/dev/sda5: UUID="87d54eaf-0b0f-3394-a33a-832cd486d919" LABEL="Shared" TYPE="hfsplus" (Shared Partition (unjournaled))

My fstab entry for the Shared partition looks like this:

UUID=87d54eaf-0b0f-3394-a33a-832cd486d919 /home/kael/.archive     hfsplus    auto,exec,rw,user  0 0

However, when I boot my computer and run mount, the result is this:

/dev/sda5 on /home/kael/.archive type hfsplus (rw,noexec,nosuid,nodev)

I've tried running mount -t hfsplus -o remount,rw,exec,user /dev/sda5 /home/kael/.archive, but it doesn't even seem to acknowledge the options I give it. Nothing changes. I can't find any error messages, either. I've looked through all of the logs and can't find any messages about that partition.

Any thoughts or suggestions would be appreciated.

share|improve this question
I think it's related to this: superuser.com/questions/84446/… – slm Sep 10 '13 at 23:18
@slm thanks for the link, but this is a separate issue. Linux doesn't have access to the journal on HFS+ drives, so the only way to enable RW on an HFS+ is to disable the journaling (which I've done with success). My question has to do with mounting the drive with execute permissions, since it's already mounting fine RW. – kael Sep 10 '13 at 23:30
OK, I've had issues with HFS+ on Linux and was steering you to this on the off chance it was the same issue. – slm Sep 10 '13 at 23:32

Try putting "exec" after "user".

"man mount" states that the user option "implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option line user,exec,dev,suid)".

share|improve this answer
Just saw this comment. Unfortunately I've since ditched my Hackintosh, so can't test this solution. I remember having tried had mixed luck with that, though. The order does matter, you're right. In my case in particular, though, I don't think it helped (though there's a chance my memory is failing me, because I did eventually fix the issue, I just stupidly forgot to post back here). – kael Nov 30 '14 at 6:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.