Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How can I configure a custom display resultion for xrdp sessions? I want the session to use all the display size, minus few lines for the original decorations. that will be around 1920x1050, a resultion that isn't available in xrandr.

I'm using i3 as wm, so there is no GUI or DE configuration tool.

share|improve this question
add comment

3 Answers 3

I don't have rep to upvote or comment on schaiba's answer, but in Fedora 19, disabling xrandr is a workaround to force the resolution.

sudo yum install -y dconf-editor
dconf-editor

browse to org -> gnome -> settings-daemon -> plugins > xrandr and uncheck Active

I can now connect using rdesktop and force a resolution.

rdesktop -g 800x600 192.168.1.xxx
share|improve this answer
    
I don't have the rep to vote him either, otherwise I would since it did help like I said in my comment. However, Gnome isn't synonimous with fedora, and I sont have Gnome installed on my system so the bug part wasn't my issue. I still don't know where or how to set the xrandr settings so that they will affect only xrdep sessions. –  Dave's tux Sep 11 '13 at 17:20
add comment

Reading the docs I can't really see such option for xrdp's command line or xrdp.ini, but what I do see is Fedora bug #973486, which might help you. Looks like a bug in gnome-settings-daemon and the suggested workaround is disabling the xrandr plugin in g-s-d.

share|improve this answer
    
I guess I should have mentionend it, I'm using i3 and It's a minimal installation. I don't have gnome on the system. I probably can solve the issue by installing xfce and setting it from there, but that defeats the target of keeping minimal installtion. –  Dave's tux Sep 10 '13 at 19:58
    
Okay, that did help me to solve the problem. added the lines menitioned in the article to shell script and added that script to the start of my .i3/config file. I still wish I knew how to run the script only on xrdp sessions. –  Dave's tux Sep 10 '13 at 22:17
add comment
up vote 0 down vote accepted

OK, following schaiba's link to the bug report, I have created .sh script with the following lines:

#!/bin/bash
xrandr --newmode "1920x1040_60.00"  165.50  1920 2040 2240 2560  1040 1043 1053 1079 -hsync +vsync
xrandr --addmode VNC-0 "1920x1040_60.00"
xrandr -s 1920x1040

after chmod +x the file and putting it in my ~/.vnc folder it gets executed when I login with xrdp.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.