Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

This question already has an answer here:

I've installed Skype by using dkpg and when I try to run it, this is what I get -bash: /usr/bin/skype: No such file or directory. Which is very strange since ls -l | grep skype shows this:

-rwxr-xr-x 1 root   root    30717480 May  7 01:43 skype

I had similiar problems when I installed FireFox, but since I didn't need it all that much, didn't care. However, I do need Skype on Linux.

Output of my $PATH variable:

/home/max/.rvm/gems/ruby-2.0.0-p247/bin:/home/max/.rvm/gems/ruby-2.0.0-p247@global/bin:/home/max/.rvm/rubies/ruby-2.0.0-p247/bin:/home/max/.rvm/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

Anyone care to explain?... Because I'm stunned.

share|improve this question

marked as duplicate by Gilles, slm, jasonwryan, Anthon, rahmu Sep 10 '13 at 7:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
have you tried to run using absolute path ? like /usr/bin/skype –  Rahul Patil Sep 9 '13 at 14:58
    
I've tried it now... and still the same result. –  radical_edo Sep 9 '13 at 15:09
    
ldd /usr/bin/skype –  Rahul Patil Sep 9 '13 at 15:29
add comment

1 Answer

up vote 1 down vote accepted

It seems that this is the perennial 32-bit application on a 64-bit system issue.

Does the following help?

[root@host]# dpkg --add-architecture i386
[root@host]# apt-get update #Will take a while
[root@host]# apt-get install ia32-libs #Will download and install ~100-200 MB of data
[user@host]$ skype&
share|improve this answer
    
Yup! This was it. I did the first step, didn't follow up. With minor detail, he made me run apt-get -f install to resolve some issues, but couldn't have gone there by myself. Thanks. –  radical_edo Sep 9 '13 at 15:30
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.