Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running Ubuntu 13.04 with a 3.10 kernel, using AMD Catalyst 13.8 BETA 2 display drivers and cinnamon.

I have found many posts stating that DisplayLink is automatically supported by the 3.10 kernel, and that seems to be somewhat true since my AOC e1649fwu displays alternating maroon & marine bars:

enter image description here

I installed Catalyst with these instructions and this patch.

How can this be resolved?

dmesg

If you get this, plug in both connectors lol:

[14551.935213] usb 1-1: new high-speed USB device number 7 using ehci-pci
[14552.047227] usb 1-1: device descriptor read/64, error 64
[14552.287806] usb 1-1: New USB device found, idVendor=17e9, idProduct=4107
[14552.287822] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[14552.287831] usb 1-1: Product: e1649Fwu
[14552.287840] usb 1-1: Manufacturer: DisplayLink
[14552.287847] usb 1-1: SerialNumber: EXUD6HA022706
[14552.291034] [drm] vendor descriptor length:17 data:17 5f 01 00 15 05 00 01 03 00 04
[14552.379806] udl 1-1:1.0: fb1: udldrmfb frame buffer device
[14552.379821] udl 1-1:1.0: registered panic notifier
[14552.379841] [drm] Initialized udl 0.0.1 20120220 on minor 0
[14552.382899] hid-generic 0003:17E9:4107.0006: hiddev0,hidraw1: USB HID v1.10 Device [DisplayLink e1649Fwu] on usb-0000:00:12.2-1/input1
[14552.598567] [drm] write mode info 153

Properly connected:

[ 1795.870817] usb 5-1: USB disconnect, device number 2
[ 1803.532140] usb 5-1: new high-speed USB device number 3 using xhci_hcd
[ 1803.553869] usb 5-1: New USB device found, idVendor=17e9, idProduct=4107
[ 1803.553886] usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1803.553895] usb 5-1: Product: e1649Fwu
[ 1803.553904] usb 5-1: Manufacturer: DisplayLink
[ 1803.553911] usb 5-1: SerialNumber: EXUD6HA022706
[ 1803.557121] [drm] vendor descriptor length:17 data:17 5f 01 00 15 05 00 01 03 00 04
[ 1803.680399] udl 5-1:1.0: fb1: udldrmfb frame buffer device
[ 1803.680413] udl 5-1:1.0: registered panic notifier
[ 1803.680433] [drm] Initialized udl 0.0.1 20120220 on minor 0
[ 1803.683615] hid-generic 0003:17E9:4107.0005: hiddev0,hidraw0: USB HID v1.10 Device [DisplayLink e1649Fwu] on usb-0000:00:10.0-1/input1
[ 1803.978412] [drm] write mode info 153

data

  1. It should be well known that DisplayLink's linux support is ~0
  2. The latest solution (note the same screen) is to do these things that I don't care to: use modesetting, use xrandr (yes, xrandr could see mine)...
  3. Catalyst can't do modesetting anyways
  4. samjam claims success with the older distro & driver & ati proprietary driver (same as catalyst?)

I tried to use the new old driver udlfb and the possible catalyst/displaylink xorg.conf, but now I only get black screen.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.