Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to add another language in Debian. I have done

dpkg-reconfigure locales
locale -a
C
C.UTF-8
en_US.utf8
POSIX
ru_RU.utf8

but I don't have any result.

root@ai:/home/volkov# locale
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

The field “System Settings → locale → Languages → available languages” is empty. How do I fix it?

share|improve this question
    
Do you want to be able to type in another language? To spell check? To display it correctly in the terminal? What Desktop Environment are you using? Have you seen this? –  terdon Sep 5 '13 at 15:51
    
I want to type in another language. second and third options I don't need. The display is correctly now. –  volkov Sep 5 '13 at 16:31
    
Desktop Environment is KDE –  volkov Sep 5 '13 at 16:32
    
I added other language in Sysytem Setings -> locale -> Languages -> available languages at debian 6.5.0. now this field is empty. there only one english language. –  volkov Sep 5 '13 at 16:49
1  
You may need to install some language packs. Try sudo apt-get install kde-l10n-ru. –  terdon Sep 5 '13 at 16:50

1 Answer 1

up vote 1 down vote accepted

If you want to add another language to your KDE environment, you should install the appropriate language pack. For example, to get Russian run:

sudo apt-get install kde-l10n-ru
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.